Problem with 5.1 rear speaker

Sep 9, 2018
1
0
10
0
Hi guys i have a 5.1 set up and it works great as stereo all speaker sounds perfect but when i change it to 5.1 from sound settings my rear right speaker is dead , everything works great except this speaker i tried everything and i am losing my mind ! please help me :ouch:
 

doolittle

Distinguished
First I would swap the L/R rear speakers and see if the deadness follows the speaker or the wire (so if the same rear right speaker still not working it's either the wiring for the RR channel or the RR input). If it changes to LR dead it's the speaker itself that is the problem. If it remains RR, continue...

Next in the back of the receiver swap the RR and LR channels, and see if the problem remains RR or changes to LR. If it now changes to LR it's that wire that is the problem so replace it. If it remains, check the RR connection on the analog 5.1 input. If you have a digital input and still RR problem could be the amp has a blown channel.
 

doolittle

Distinguished
First I would swap the L/R rear speakers and see if the deadness follows the speaker or the wire (so if the same rear right speaker still not working it's either the wiring for the RR channel or the RR input). If it changes to LR dead it's the speaker itself that is the problem. If it remains RR, continue...

Next in the back of the receiver swap the RR and LR channels, and see if the problem remains RR or changes to LR. If it now changes to LR it's that wire that is the problem so replace it. If it remains, check the RR connection on the analog 5.1 input. If you have a digital input and still RR problem could be the amp has a blown channel.
 

ASK THE COMMUNITY