Razer Kraken 7.1 Chroma Problem

Xecuter34

Estimable
Nov 30, 2015
1
0
4,510
0
So I have had this problem for a little while now, simply put when I play a game like Batman Arkham Knight I get this horrible crackling in the ear cups. When I play ARK: Survival Evolved it will crackle every so often and sometimes the mic will cut out and I will have to close the game or close Synapse and re-open it.

Black Ops 3, the mic will stop working unless I lower the settings even though I can run it completely fine at the highest and even lowered there is still the chance it will cut out. Rainbow Six Siege during the Beta this weekend, the mic would stop working at random times during a match, again, even though I can run this game happily at 60fps on Ultra.

But yet a game like Fallout 4 which in some areas my computer will struggle, the microphone is completely fine, same with the ear cups so I am having a hard time figuring out what is the cause.

I have contacted Razer support and they want to test it on another PC but there is one problem with that, I do not have another high end PC that can even run these games so replicating the problem on another system is out of the question. I did post up on the Razer Forum to see if anyone could help but it was took down within minutes telling me to contact support even though I have.

Here is a video to what it sounds like and my rig to see what I am running to see if that gives you any idea: https://www.youtube.com/watch?v=k-chtK4q37s

My Rig:

CPU: AMD FX-8350 Clocked @ 4GHz
Cooling: Arctic Freezer A30
GPU: Nvidia Geforce GTX 970 4GB
RAM: 16GB DDR3 1333MHz
External HDD: Touro 1Tb USB3.0
Motherboard: ASRock 970 Extreme3
PSU: OCZ ZS Series 750W
Sound: On-Board Sound Chip
OS: Windows 10 Pro 64-bit
Keyboard: Razer Blackwidow Chroma
Mouse: Razer Naga Chroma
Monitor: Acer CB270HU @ 2560x1440

Any help would be appreciated.
 

mudpuppet

Honorable
Jun 20, 2012
28
1
10,610
7
Are you going through the sound ports on the front or back of the case and is it USB? I've heard a few people have a similar issue that sounds like it was never really resolved but I would say to make sure you check other USB ports (front and back of the PC if possible) since you can't do anything about the PC itself. I want to say there are drivers for the headset as well so you can update those, or try uninstalling them all together as I don't think I ever installed them and I've had 0 issues over the last few months. If it's only the headset and other headsets/mics/speakers seem to work just fine, that would rule out the onboard sound and point back at the headset. If you can't test it on another PC (like at a friends) see if you can find other sound devices to test on your PC. Hopefully that would be good enough for Razer to do a replacement or something.
 

Finn D

Estimable
Jul 4, 2014
1
0
4,510
0
This happens sometimes when i open Just Cause 3. I have only realised that it happens when I have the speakers on my monitor disabled. Maybe try enabling them before you open the game and see if that works :D
 
Thread starter Similar threads Forum Replies Date
V Audio 3
F Audio 5
razetea Audio 4
P Audio 3
G Audio 1
J Audio 2
S Audio 4
J Audio 1
S Audio 1
M Audio 1
C Audio 2
C Audio 2
A Audio 3
P Audio 1
I Audio 2
P Audio 2
C Audio 1
R Audio 1
T Audio 1
B Audio 3

ASK THE COMMUNITY