Razer kraken pro mic picking up everything in the headset

kjetta95

Honorable
Sep 17, 2013
5
0
10,510
0
My new Razer Kraken Pro headset mic is sending everything i do on the computer to the ones im takling to on teamspeak or skype. If i play a song on iTunes or is in game or on YouTube the one im takling to can hear everything, and me very low. I have an Asus g55vw. Any tips would be helpful!
 

Shaun o

Distinguished
I just don`t get it.

There are only two ways that would happen.
First of all in windows the headset should be setup as a default communications device.

If someone can here what music you are playing it means you are running a set of speakers playing music ect.
At the same time.

If you are and your intention is to hear Teamspeak chat, and in game sounds, or playing music. Without them hearing it.
Then set the device from default communication device to default device in windows.

In windows 7 right click on the speaker icon next to the time.
Select playback devices.
Right click on headphones, set as default device.
 

kjetta95

Honorable
Sep 17, 2013
5
0
10,510
0


Sorry. But i can't seem to find the headset icon yuo're talking about. And i'm not having any other speakers on either. it's only the headset that is on, and of some strange reason the microphone picks up everything i do on the computer..
 

kjetta95

Honorable
Sep 17, 2013
5
0
10,510
0


i've too checked all over razer and it doesn't really say much about my problem..
 

John Bauer

Honorable
Jul 16, 2013
53
0
10,590
2


This is off of the website:

The microphone is overly sensitive and picks up sounds other than my voice. How can I fix this?
Here are a few suggestions that may help: Be sure the microphone is fully extended when in use. If you try to use the mic in the stored position you will pick up sounds from your speakers.
Ensure ""Listen to this device"" is not selected under Control Panel >Sound > Recording > Properties > Listen
Check your sensitivity levels are not set to max or boosted too much. Control Panel >Sound > Recording > Properties > Levels
Insure that only one voice chat application is in use while in-game
Check that you are configured to use the proper microphone. Control Panel >Sound > Recording > Select proper Microphone > Set Default Device/Communications Device

"Insure your computer supports the combined audio jack, if not use the included splitter."

What about this?
 

kjetta95

Honorable
Sep 17, 2013
5
0
10,510
0


Yeah. I went trough this one too a couple days ago because it was closest to my problem, but it didn't help either:(
 

Shaun o

Distinguished
Hold on, that means the mic is in the line in port.
Not in the mic port.of the back of the computer if plugged in there.

If you do not get Default communications device in playback devices.
But line in is activated.

You plugged the mic into the wrong port.



 

kjetta95

Honorable
Sep 17, 2013
5
0
10,510
0


I have a laptop Asus g55vw..
 

tim g

Honorable
Dec 1, 2013
1
0
10,510
0
I have been experiencing the exact same problem since I bought my new gaming headset. The mic is really quiet so I had to turn the boost up to 30db, which caused a little static and made the microphone too sensitive to ambient noise. Like you if I played music whilst in a voice chat my friends could hear me and it would cause a bad echo; they could also hear their own voices being picked up through my mic.

After doing some recording tests with music playing I finally figured it out, and now I know why I had no issue with my old USB headset. I had the jacks plugged into the front of my computer for ease of use and since I've got my surround speakers plugged in the back (5.1 channel). Once I unplugged those and connected my headset jacks (speakers and mic) at the rear of my PC I got no static and my music stopped being picked up through my mic.

It's a pain I can't have my speakers and headset plugged in at the same time, but it's works now so that's good. Hope that helps because I've seen this problem all over the internet and have been unable to find a solution outside of the obvious changes and alterations to sound settings in Windows and through my sound card manager.
 

Zalphor

Estimable
Aug 14, 2014
2
0
4,510
0


Try using whatever echo reduction features you can find in your OS/ VOIP(teamspeak 3, raidcall, skype, ect) program, usually near the mic sensitivity option there will be echo reduction options + ensure that the sensitivity is at a very balanced level. And lastly try not to pump up the volume too loud as the kraken pro is more like a set of head speakers than a set of headphones. Good luck as this was litterally one of my first issues when using the kraken pro. Also I read most of the posts but not all so I don't know if someone has already stated this.

Edit: Oh btw it took all 3 of teamspeaks echo reduction/handling options to get the desired effect.
 

Zalphor

Estimable
Aug 14, 2014
2
0
4,510
0


Last edit: after my friend got a pair also I remembered that it automatically turns on "listen to this device" meaning it will play your mic over your headphones until you turn off "listen to this device" in the microphone properties. Just thought I'd conclude this forum a little bit more. If you don't know where to find your mic properties then just right click on the volume control in the lower right of windows and select recording devices.
 

Frank Pongratz

Estimable
Sep 2, 2014
1
0
4,510
0


My solution. This just happened to me, it was because the headphone jack that connects in the middle of the wire was slightly disconnected but still enough to hold in place. make sure it's pushed in all the way
 

tearherup

Estimable
Dec 26, 2014
5
0
4,510
0
The reason is a hardware design flaw the power for the headset is usb and the computer is confused where to send the audio. Buy a 6 foot usb extension cord and use a usb wall charger for power. That will fix the problem.
 

Mintalicious

Estimable
Feb 21, 2015
1
0
4,510
0
I figured it out!
Ok so go to Control Panel >Sound > Recording > Properties > Listen
Click the drop down bar that says Playback through this device:
I chose my default playback device, which are my speakers, but they are turned off.
Try using different ones and see what happens.
Eventually, it won't pick up what sound is going off your computer!
 

Rok Tisovic

Estimable
Aug 5, 2015
1
0
4,510
0


This was the root to my problems, i have solved it before, but i have forgotten how to, today with windows 10, it came back & i spend 4 hours trying all the possible combos with control panel > sound > recording and listen. none of them worked, and then i tried my last shitty option and i did this in realtek HD, restarted the computer and it worked like a charm. no sound went thru except my voice, and i had song "Captain hook - Bungee jump" on 100%.
 

Brett_10

Estimable
Jan 6, 2016
1
0
4,510
0

You have to click the sound icon the click the speaker icon above the sound bar then go to levels and change realteck adiou output from 100 to like 50
 

RRRRIP

Commendable
Sep 30, 2016
1
0
1,510
0


THIS! This was 100% my problem and this solution fixed it!!!
 
Thread starter Similar threads Forum Replies Date
sparikle Audio 1
K Audio 1
P Audio 0
George0705 Audio 0
hamoodhabibi Audio 1
Johnathon TwinkleToes Audio 0
Epic gamer Siller Audio 2
Nonamekeke Audio 0
Sibbe Audio 1
krieghalp Audio 1
D Audio 1
filthyspoons Audio 0
S Audio 0
tophatclay Audio 0
B Audio 1
O Audio 1
B Audio 2
I Audio 7
B Audio 3
D Audio 12

ASK THE COMMUNITY