Question RCA Galileo Pro 11 is constantly repeating "Unfortunately" messages, for multiple Apps, that stopped Servicing ..please help.

Mar 26, 2020
1
0
10
0
Hi I hope someone can help me with this.. purchased my RCA Galileo Pro in 2017. (3 to be exact within the past 3 years)

One of them will not go past the 2nd part of the "Welcome"page. It just says "Just s second " forever. Also with messages constantly repeating " Unfortunately, Google Play Services has stopped" Unfortunately, Chrome has stopped" Unfortunately, Maps has stopped"
These is what I've done so far to try to fix it.
I have completed "Safe Mode" turned on, but won't go past Welcome"s 2 page. A "Hard Reset" turn on, nothing changes. "Wipe Cache Partion", "Wipe Data/Factory Rest", "Rebooted System Now"... multiple times and both "Wipe" watches with completed multiple times as well.

I did a "Root Integrity Check ". That failed and also found 12 Errors. (Don't know what that means or how to fix it).. I've also completed a reset on the back hole by using a needle because I tried to complete a "Reboot to Loader".. but it only showed "Fastboot Reload" for 20 min... nothing else. Could not turn it off, but the back reset hole worked to restart.

All these things are not getting me anywhere and with the Covid -19, my Kids have to stay home and do virtual classes now. My husband and I are both laid off and warranty has past, so can't afford new ones.
I purchased 3 of these in the past 3 years and they all had the same activities on them and Appps. Don't understand why it's doing this...

Could anyone please give me some advice on how to bypass all those "Unfortunately" messages or how to go about fixing the "12 Errors" found on the "Root Integrity Check?"

Blessings.

Oh BTW model number is 11 Galileo Pro RCT6513W87DK-:giggle:
 
Last edited:
Thread starter Similar threads Forum Replies Date
Harlie Android Tablets 3
N Android Tablets 2
S Android Tablets 1
I Android Tablets 1
R Android Tablets 1
S Android Tablets 1
Z Android Tablets 1
N Android Tablets 1
L Android Tablets 1
D Android Tablets 1
M Android Tablets 1
M Android Tablets 1
X Android Tablets 5
S Android Tablets 1
D Android Tablets 1
J Android Tablets 1
F Android Tablets 1
N Android Tablets 5
A Android Tablets 4
T Android Tablets 1

ASK THE COMMUNITY