Question RCA stuck on logo

Dec 19, 2018
6
0
10
0
I did a hard reset and it will either freeze on log or go to the welcome but then I get Google played has stopped , I click ok and it a loop between Google play has stopped and tapping ok. I've read several threads about this issue and I keep seeing do a hard rest well I have I have selected every option in the recovery mode I can. And it hasnt helped.. this is one of my children's tablets that was already having major issues.
So it leads me to this question, is there away to reinstall the OS, I have 2 more tablets exactly the same bought at same time in the house if that helps any. Thanks in advance.
 
Having more of the same tablet wouldn't make any difference in the case of the OS being a problem.

When you did the reset, did you choose the option to save any of the data on it? If so, it wasn't a true "Hard Reset" and would run into problems. Not uncommon. The reason being, if there was something on the tablet that was a cause of the problems, nothing other than a full "Hard Reset" would ever remove it. I would suggest (even though I did see what you said above) to do a "Hard Reset" using the instructions I will include below.

If that doesn't resolve it, then there may well be a problem with devices storage, which is not something you could easily fix. If it is under warranty, then I would suggest contacting the manufacturer. If it isn't, then you may want to try a local tech, or just get a new device, depending on what is cheaper.

A side note, while one could suggest trying to root the device and then install the OS from some location online (you couldn't get it from the other tablets), I would never recommend that as there are way to many risks, one of which is bricking the device.

To "Hard Reset" the tablet...

1. Make sure that the tablet is actually powered off.

2. Remove your SD card, if there is one in the device.

3. Press the "Power" and the "Volume Up" buttons, together, until you see the start-up logo on the screen.

4. Once you can see the logo, release the buttons and allow the device to enter the "System Recovery Mode".

5. Next use "Volume Down" button to get to the "wipe data/factory reset" option.

6. When in recovery mode the "Volume Up" and "Volume Down" buttons are how to can navigate and highlight what option you need.

7. Once you have selected the "wipe data/factory reset", press the "Power" button to select that option.

8. On the following screen, repeatedly press the "Volume Down" button until the "Yes - delete all user data" option is what is selected.

9. Then press the "Power" button to hard reset the tablet.

10. If you took your SD card out in step 2, when the device is up and running again, reinsert the SD card.
 
Dec 19, 2018
6
0
10
0
Hey sorry, I didn't get a notification anyone had commented, just popped on to check. And no I did not save anything, didnt back up or even have a sdcard inserted. I did do a hard reset, using hot keys from recovery mode not from settings>about device>factory reset ( my experience, resetting from the setting on any device doesn't fully reset, I always preformed fdisk on computers, when i worked on them yrs ago, instead of just format for same reason). I think the tablet had malware as she loaned it to her cousin who is 15 and is.. well you were 15 once imagine that times 100.. lol I just went up and finished reading your reply. I did those exact steps to preform the reset. Then when it was stuck on logo, I went back in and deleted the cache partition as a friend suggested and that got me to just one sec screen and the Google play serves has stopped dialog boxes repeatedly. Think I could do anythibg using adb , my new laptop will be here today. I've only had a chromebook and my phone and neither have been much help even being on dev mode. I've contemplated flashing but have never tried it before. Thanks for the reply :)
 
Last edited:
I sit possible that the person who had the tablet messed with it, installing an alternate version of Android after rooting the device? If so, that could cause this issue.

If the tablet is under warranty still, the safest thing would be to contact the manufacturer, as they can then either replace it or repair it. If it isn't, well, to be honest I would get a new one before I would try installing anything on it yourself. While you could (although personally I am not a fan of that or the rooting either) it seems more likely that the memory could be damaged.

Just a thought.
 
Thread starter Similar threads Forum Replies Date
K Android Tablets 0
U Android Tablets 1
Game stark Android Tablets 0
I Android Tablets 2
Shenelby Android Tablets 1
Auster1805 Android Tablets 0
R Android Tablets 10
S Android Tablets 8
scwolves10 Android Tablets 5
SaturnSolar Android Tablets 1
J Android Tablets 1
Jduacouple Android Tablets 3
Somniax0x Android Tablets 1
vidgirl94 Android Tablets 1
Sia111 Android Tablets 6
P Android Tablets 1
J Android Tablets 1
S Android Tablets 1
J Android Tablets 1
R Android Tablets 1

ASK THE COMMUNITY