Record Player's Speakers constantly crackling and giving feedback.

chalkoss

Estimable
Jan 12, 2015
1
0
4,510
0
My record player is a Sharp Golden Sound cabinet unit with unknown speakers. I bought it midway through 2014 and it has been working fine ever since. Recently however there has been constant feedback and popping sounds whenever I turn on the speakers (not when a record is playing). The process of turning the system on is to power up the amp/tuner then to flick a switch to turn the speakers on (they have wire connections which i have redone since they were quite frayed, however if it is a likely problem please let me know), it is when I flick this switch that the feedback and frequent crackling sounds start. It happens no matter which setting I have the system on (phono, tape, radio etc) and doesn't seem to increase in volume and I turn up the volume switch, any help would be much appreciated since I don't want to have to take it somewhere to get it repaired, thanks! Note that the noise is coming from both speakers, leading me to think that they are not the issue but rather the amp.
 
You are correct that the speakers cannot make any noises unless they are being played. Sounds like that old amp needs to be restored. Noisy transistors and bad capacitors may need to be replaced, When you say "feedback" I think you may mean hum. Feedback only happens if the speakers are playing music which is then picked up by the turntable and feed back to the speakers again.
 
Thread starter Similar threads Forum Replies Date
M Audio 3
S Audio 5
S860 Audio 1
T Audio 6
J Audio 1
C Audio 8
J Audio 4
K Audio 4
J Audio 4
H Audio 1
T Audio 3
T Audio 1
B Audio 5
J Audio 2
R Audio 1
B Audio 1
E Audio 1
M Audio 1
K Audio 9
Z Audio 1

ASK THE COMMUNITY