selfdefined java buttons do not show correctly

Status
Not open for further replies.

pingcandle

Estimable
Mar 16, 2015
4
0
4,510
0
hot link buttons dont show right.
Buttons show only as hexadecimal value.
The buttons work, but show wrong.
bad java update problem?
path to the selfdefined class wrong/missing?

In the inspector of firefox, it shows, it's a selfdefined class. like ....class=...."

I didnt define the buttons.
Same goes for this tomshardware site: The search Icon shows as a capital E, while a right click shows correct for "Search".
Instead of "tom's hardware" I see only "t H"
And many buttons show only as foreign Letters, like N with ~ eg hovering on it shows the "Quick Edit" bubble correcly.

How to fix this?

using firefox 36, windXP,
neweset java update 11.31, which deleted most older versions as java recommends -bad idea?
 

pingcandle

Estimable
Mar 16, 2015
4
0
4,510
0
It seems to me that t H is using a very old, vulnerable java version, which got removed by java with the newest update (now it's java 11u45)
Should I reinstall an old version, like java 7?
 

SinxarKnights

Distinguished
Jan 3, 2007
91
0
18,610
22
Is there Java on this site? That is news to me if true.

What do you need browser java for if you don't mind me asking? Personally I only use Java these days for Minecraft but that uses the standalone version.
 

pingcandle

Estimable
Mar 16, 2015
4
0
4,510
0


Not sure why you are answering here.
My problem came after a java update removed old java versions, which I allowed, while knowing it will cause major problems.
Whatever script with classes t H uses, maybe newer java versions disallow and block unsafe and vulnerable script versions also?
t H is known for being an unsafe site, I heard.

(I don't know, if the login disaster was there before these updates. Why can I answer before logging in and cannot log in after I typed my answer?)
 

SinxarKnights

Distinguished
Jan 3, 2007
91
0
18,610
22
Java has nothing to do with JavaScript (JavaScript is used on Toms, not Java). Very few websites use Java at all.

Are you running NoScript or another type of script blocker? If not you may want to check for unwanted addons. Have you tried in another browser or using Firefox with the no addons option to see if it persist?

 

pingcandle

Estimable
Mar 16, 2015
4
0
4,510
0


I tried IE8 and firefox37 without Add-ons. Similar result.
no reply possible in IE8.
I could not figure out what m and i or l means. (moi). They dont do anything.

cpu always on 100%, -unusable.
cannot continue testing.
crawling to death by advertisement?

But I found an improvement by "Allow pages to choose their own fonts" in firefox. tools-options-content

thanks, for me: solved!


 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
9 Apps General Discussion 1
M Apps General Discussion 1
Z Apps General Discussion 6
S Apps General Discussion 1
B Apps General Discussion 2
kep55 Apps General Discussion 4
J Apps General Discussion 1
D Apps General Discussion 3
A Apps General Discussion 3
G Apps General Discussion 0
D Apps General Discussion 3
M Apps General Discussion 1
M Apps General Discussion 4
N Apps General Discussion 6
Cap17 Apps General Discussion 16
R Apps General Discussion 29
M Apps General Discussion 1
S Apps General Discussion 1
B Apps General Discussion 17
ntmk11 Apps General Discussion 1

ASK THE COMMUNITY