Sennheiser HD650 audio really quiet

DangerDan

Estimable
Nov 29, 2015
6
0
4,510
0
I've recently purchased a pair of HD650s to be used with a Schiit magni 2 . When connected to the amp the audio output is very quiet and almost inaudible until the amp is turned up to around 70 percent even with a high gain. Is this normal? Otherwise could someone help fix the problem with the setup

http://imgur.com/wuK8fcR

Thank you for taking the time to read this as I'm completely new to amps to audiophile headphones.

 
There may not be any problem.
Cheap audio equipment uses cheap linear volume controls that reach almost full volume at about 12 o'clock. You think you have more volume available than you actually do.
Better audio equipment have better logrithmic volume controls that use the entire rotation of the control. Gives you much finer control. Log pots work the way your ear works.
So long as you can play louder than you want to don't worry about the position of the control. The best sound is when the control is all the way up which puts it out of the circuit.
 

DangerDan

Estimable
Nov 29, 2015
6
0
4,510
0



I was just worried that the headphones were not properly being powered by the amp, or that there was a problem with the amp or cable setup as this is my first time using an amp with headphones.
 
Thread starter Similar threads Forum Replies Date
C Audio 1
V Audio 1
F Audio 1
M Audio 0
M_RiGGz Audio 5
F Audio 3
maveick Audio 4
JackGarrison Audio 1
rclr Audio 2
F Audio 1
K Audio 1
N Audio 26
T Audio 1
N Audio 2
M Audio 10
L Audio 1
M Audio 2
KR2 Audio 1
A Audio 9
J Audio 1

ASK THE COMMUNITY