Speakers make pop sound when turning amp on/off.

skaz

Distinguished
Jan 1, 2011
178
0
18,660
8
Hello,

I bought a little t-amp lepai 2020a+ and a pair of polk monitor 30s for my pc set up. When I turn on or off the amp my speakers make a quick pop sound. I've heard slight poping sounds when turning on other speaker sets (smaller speakers) but they never sounded as loud as my issue now. Volume is turned all the way down and source material is on.

Is this common and safe for the speakers or should I be concerned? Can it damage the speakers over time?
 

jacobboe89

Distinguished
Jul 15, 2011
112
0
18,660
6
this sort of thing can be typical for cheap amplifiers or amplifiers that are based off of old designs . now whether or not this will harm your speakers is hard to say without hearing them myself .of course this would make any one feel a bit uneasy .if you wanted to try to protect your speakers you might install fuses inline on the positive speaker wire .i would start by trying a small fuse and definitely a fast blow , small like .25 amp , not sure how much smaller they get .not totally sure if this would adequately protect your speakers .
 

skaz

Distinguished
Jan 1, 2011
178
0
18,660
8
I would also like to note that I removed the speaker grills from the polks. And when I turned on the amp I noticed the woofer move slightly. I didn't notice the woofer move at all when turning the amp off though.
 

jacobboe89

Distinguished
Jul 15, 2011
112
0
18,660
6
this sort of thing can be typical for cheap amplifiers or amplifiers that are based off of old designs . now whether or not this will harm your speakers is hard to say without hearing them myself .of course this would make any one feel a bit uneasy .if you wanted to try to protect your speakers you might install fuses inline on the positive speaker wire .i would start by trying a small fuse and definitely a fast blow , small like .25 amp , not sure how much smaller they get .not totally sure if this would adequately protect your speakers .
 
This may relate to your other post about hearing the drive noise through you speakers. You are getting a dc pulse when the amp is turned on. Disconnect the amp from the PC and then turn it on. If you are getting the pulse then there may be a problem with the amp. There should be dc blocking at the output to prevent this.
 

skaz

Distinguished
Jan 1, 2011
178
0
18,660
8
Yeah it seems the amp just has no "mute". I talked to a tech from parts express about it. Going to replace it though because it erks me. Haha. Going to try a topping that supposedly has a "mute". I do believe it is a seperate issue from my Emi I'm getting. Thanks for the replys.
 

skaz

Distinguished
Jan 1, 2011
178
0
18,660
8
FYI for anyone who needs the info. The amp was cheap and was the cause of the annoying sound like jacob said. I Replaced the lepai with a Topping TP30 and the speakers make no sound when turning on. Plus I think the sound is more detailed with the Topping vs the lepai. Over and out. bzzt.
 
Thread starter Similar threads Forum Replies Date
G Audio 1
C Audio 2
C Audio 3
hong_kong_dusk Audio 4
P Audio 0
Beekay_ Audio 0
FirstLast1234 Audio 3
Tombo9 Audio 3
HoomanSacrifice Audio 12
B Audio 5
Vincent14 Audio 1
M Audio 1
A Audio 2
B Audio 14
T Audio 2
S Audio 3
S Audio 1
revolultrablue Audio 7
B Audio 1
L Audio 3
Similar threads
Question No sound at all when plugging speakers when plugging headset in
Question Are there sound bars I can use as left, center, right speakers for my home theater system?
Question Is it feasible to have a home theater system with the soundbar as the only front speaker?
Question PC monitor still outputs sound through its speakers when I plug in headphones to it
Question Any recommendations for a good sound quality bluetooth speaker for outdoor party.
Question How to collect sounds from dual monitors to a single speaker?
Question Sound only coming from one speaker?
Question I want to play sound out of a phone speaker from a computer (via Bluetooth?)
Question Vizio Surround Sound speakers not working SB3581
Question Subwoofer on 2.1 speaker system not working(Logitech Z623) when connected via aux
Question Speaker sound output
Question Creative T15 Wireless playing sound only from left speaker when using aux
Question Hello, I have AOC u2868pqu and also no sound coming out of the built-in speakers. I found out the speakers only work only when PIP/PBP is turned on
"something went wrong while trying to turn on spatial sound" Dolby Atmos
Buzz sound in speakers when bathroom shower pump turned on
Speakers Popping sound....turns off my USB audio interface
When I turn on my home stereo when I turn the equalizer on it since it popping sound through the speakers
Sound blaster z turns off full range and surround settings on restart
Bose speaker problem with having a humming/buzzing sound when turned on.
Speakers turn on/off every time sound is played

ASK THE COMMUNITY