T3i mount for Makinon?

Day_2_

Commendable
Jul 3, 2016
2
0
1,510
0
Hi, so I have a rebel t3i camera and recently got a Makinon 4.5 80-200mm. Now through my research I found that it was suppose to take a pentax pk mount. I bought one and it fits the camera but not the lens. I was just wondering if someone could help me out by telling me the lens mount needed. I'm not worried about any auto functions I'm fine with manual, just want the lens go fit the camera.
 

kenrivers

Splendid
Moderator
Hopefully the third one will work and your experience will be better than mine was. I have a Takumar zoom lens that came with the Pentax K1000 I bought many years ago. To keep it brief I purchased the adapter and got it to fit the T4i. It was all downhill after that and I never have been able to get the lens to work properly. I followed the directions but may have missed something.
 

kenrivers

Splendid
Moderator
What adapter did you buy? Did you buy a PK mount to EF mount adapter? Could you post a picture of the end of the lens that connects to the camera? I have seen one of those lenses that has a threaded mount (Pentax M42).
 

Day_2_

Commendable
Jul 3, 2016
2
0
1,510
0


I have two lens mount adapters right now, one is a Pentax K PK to EOS (https://www.amazon.com/gp/product/B008OQ0L2O/ref=oh_aui_detailpage_o02_s00?ie=UTF8&psc=1)
a Fotodiox OM to EOS
(https://www.amazon.com/gp/product/B001G4NBNC/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1)

And I have a Fotodiox M42 to EOS on the way
(https://www.amazon.com/gp/product/B001G4QXN2/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1)

The First two I have don't fit it and I don't know about the third yet. But here are some pictures of the lens end and the mounts:
https://drive.google.com/folderview?id=0B98iex1YYZ3GNkNKX1pmaHh5V2s&usp=sharing
 

kenrivers

Splendid
Moderator
Hopefully the third one will work and your experience will be better than mine was. I have a Takumar zoom lens that came with the Pentax K1000 I bought many years ago. To keep it brief I purchased the adapter and got it to fit the T4i. It was all downhill after that and I never have been able to get the lens to work properly. I followed the directions but may have missed something.
 

ASK THE COMMUNITY