Toshiba Satelite Laptop USB 3.0 not working

wrathofdragon

Honorable
Nov 26, 2012
19
0
10,590
6
I have several USB 3.0 Hard drives, yet when i connect them to my laptop, they use USB 2.0 (flashes blue when usb 3.0, white when usb 2.0) i tried to connect them to my sister's ASUS laptop, and it used usb 3.0 (even though my laptop is newer and better than hers)

The hard drives are a Seagate 1TB and a TOSHIBA 1TB. they work on different Computers (they are fine)

My laptop is a toshiba satelite s855 (s/n 5c307627q) Core i-5 with 6gb ram (no bottleneck there) i have 2 USB 3.0 (blue) ports that i use for the hard drives. the hard drives flash blue, and then start flashing white. i checked my Toshiba Drivers, (USB 3.0, and USB filter driver (intel)), and even tried to reinstall them. but the laptop still uses usb 2.0

I play games off of that hard drive (steam installed there) and i would like to be able to not lag on such simple games as counter strike source and half life 1. thank you for your time. if you have any questions or need additional info, just ask.
Images:
 

wrathofdragon

Honorable
Nov 26, 2012
19
0
10,590
6
i found the answer to it. even though in BIOS i had USB 3.0 enabled, when i opened start menu, and searched HWSetup (toshiba setup station) there was an option under USB that said USB 3.0 Host Controller Enabled or Disabled, ==> it was disabled, so after i enabled it, the computer restarted and i had USB 3.0 working again.
 

wrathofdragon

Honorable
Nov 26, 2012
19
0
10,590
6
i found the answer to it. even though in BIOS i had USB 3.0 enabled, when i opened start menu, and searched HWSetup (toshiba setup station) there was an option under USB that said USB 3.0 Host Controller Enabled or Disabled, ==> it was disabled, so after i enabled it, the computer restarted and i had USB 3.0 working again.
 

Szecska

Estimable
Jun 23, 2015
1
0
4,510
0


Hi!
I have the same problem (usb 3 ports works as usb 2). I downloaded HWsetup (ver. 4.x) but it hasn't got a USB 3.0 Host Controller option in the USB tab. Which version do you use? There is a bios setting for usb 3 but it is enabled. I installed usb 3 driver from Toshiba support site but still not working.
I have Satellite L850 with Win 8.1 x64
Anybody know solution?
Thanks
 
Thread starter Similar threads Forum Replies Date
tiltawhirl Laptop Tech Support 1
J Laptop Tech Support 2
B Laptop Tech Support 1
D Laptop Tech Support 1
E Laptop Tech Support 3
R Laptop Tech Support 1
A Laptop Tech Support 1
O Laptop Tech Support 1
D Laptop Tech Support 1
J Laptop Tech Support 1
D Laptop Tech Support 2
D Laptop Tech Support 1
B Laptop Tech Support 1
A Laptop Tech Support 2
L Laptop Tech Support 9
L Laptop Tech Support 3
P Laptop Tech Support 2
V Laptop Tech Support 1
Y Laptop Tech Support 3
R Laptop Tech Support 5

ASK THE COMMUNITY