Toshiba Satelitte p300 notebook black screen after Splash Screen

Chris Law

Estimable
Feb 13, 2015
6
0
4,510
0
(PLEASE MOVE INTO THE RIGHT THREAD AS I KNOW ITS THE WRONG ONE BUT I COULDNT FIND ONE THAT MATCHES THIS THREAD!!!!)


Hi, I have an old Toshiba Satelitte, i haven't used it for a long time so out of curosity, i thought i might boot it up. But after the splash screen with the toshiba logo and the Hotkeys, it just goes to a lit up black screen, nothing else. Cant do anything.

I thought switching the SSD and the RAM would help, Nither did. I cant swap the RAM because I cant find one that fits. And the SSD's I used (Which was 5 of them including the one that came with the laptop) just came with the same problem. But not the same problem on any other computers.

Please help! I really want to get this sorted!

SSDs I used incase you wanted to know:


  • WD Scorpio Blue, 500GB
    Seagate Momentus Thin 320GB
    Fujitsu (No other markings, this one came with the laptop)
    An unmarked white one from a Dell 5450 Win 8 computer
Maybe the OS has just disappeared?

Thanks!
 
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 2
Reverse_Hex Laptop Tech Support 4
O Laptop Tech Support 0
Dareom Laptop Tech Support 7
Q Laptop Tech Support 2
G Laptop Tech Support 0
C Laptop Tech Support 1
S Laptop Tech Support 4
james.lahir42 Laptop Tech Support 4
T Laptop Tech Support 1
B Laptop Tech Support 3
R Laptop Tech Support 0
V Laptop Tech Support 0
S Laptop Tech Support 1
S Laptop Tech Support 0
2 Laptop Tech Support 3
E Laptop Tech Support 2
L Laptop Tech Support 2
L Laptop Tech Support 2
G Laptop Tech Support 2

ASK THE COMMUNITY