Toshiba satellite c850 fails to boot & black screen

Jdowns

Commendable
Jan 14, 2017
1
0
1,510
0
My Toshiba satellite c850 stopped working yesterday. Battery was drained at some time during the day, then we plugged in and started came up with lines of screen instead of starting normally. Turned off, now only gives me a black screen with not boot and fans / drive spinning. Tried a numebr of times taking battery out holding the power butto and putting back in, but still no luck. Any suggestions?
 
When you did the 'battery out/hold button' did you do it the following way? If not, try it. :)

1. First make sure the device has been charged.
2. Unplug your charger cord.
3. Remove the battery.
4. Press and hold the "Power" button for 30 seconds and see if the device will turn on.
5. If it does, great, if not yet, no big deal. Now plug back in the power/charger cord. (If it didn't turn on without the cord in, it should turn on once you it is in. Yes sometimes they will turn on, or try to turn on, even with nothing attached/plugged in.)
6. Now put the battery back in.

If this doesn't help, then test the power cord to see if it is good. Either try your cord in another device, or try another devices cord in your laptop.

Should that not be the problem, then check the battery to see if it needs replacing.

 
Thread starter Similar threads Forum Replies Date
wolfluvr Laptop Tech Support 1
J Laptop Tech Support 3
A Laptop Tech Support 1
Bluemoon1502 Laptop Tech Support 1
G Laptop Tech Support 3
O Laptop Tech Support 5
D Laptop Tech Support 1
XVII Laptop Tech Support 0
R Laptop Tech Support 1
KnottyCord Laptop Tech Support 2
ahindi Laptop Tech Support 0
Debs70 Laptop Tech Support 3
R Laptop Tech Support 0
W Laptop Tech Support 1
D Laptop Tech Support 3
M Laptop Tech Support 15
K Laptop Tech Support 3
C Laptop Tech Support 3
M Laptop Tech Support 1
1 Laptop Tech Support 4

ASK THE COMMUNITY