Toshiba Satellite doesn't fully boot

Solantis91

Estimable
May 15, 2015
3
0
4,510
Hello,

My computer is a Toshiba Satellite A660D. The specs are as follows:

CPU: AMD Phenom II P940 / 1.7 GHz Quad-Core
8GB RAM
ATI Mobility Radeon 5650 Graphics Processor
500GB SATA Hard Drive

This problem arose one day after the battery died. I heard it beep from across the room, signaling low battery, but I didn't get to it in time to plug it in. Later that day, I pressed the power button and its light came on, the fans came alive, the CD-ROM drive clicked once as it always does when it's powering up, then nothing at all. Nothing came up on the display whatsoever, and the hard drive LED never blinked once. But everything else was looking fine: the fans continued to work and the other lights remained on. I figured I just had to let the battery charge a little bit, but even after fully charging this problem has persisted. I've searched relentlessly on the internet for a solution and I've tried everything: taking the battery out and holding the power button down for 30 seconds, reseating the hard drive, RAM, display cable, and various other cables around the motherboard. Still nothing. I don't believe this is a hard drive issue because I was able to access it on another computer via SATA-to-USB cable. The only thing that came close to solving the problem was a solution I found in a forum thread related to CMOS battery issues: I left the computer on in the half-powered-up limbo state overnight and the next day it turned on just fine. This has worked a couple times now, but today I had no luck. This is very frustrating because this laptop is actually the best system I have right now and I can't afford to shell out money for something new just yet. Any help you can offer would be greatly appreciated.

 

Solantis91

Estimable
May 15, 2015
3
0
4,510
It's been over a day now and the situation has not resolved itself. Anyone out there have any thoughts? My guess is still something motherboard-related, but I could be wrong.
 

Solantis91

Estimable
May 15, 2015
3
0
4,510
It's now been well over a month and I'm seeking all the help I can get. I've completely taken the laptop apart now multiple times just to reseat everything I can possibly reseat, but with no results every time. Now that some more time has passed, does anyone out there have any suggestions before I give up completely? Anything would be much appreciated!
 

TRENDING THREADS