Toshiba Satellite S70t-B flashes white once only when power button pressed


Nov 26, 2017
I am having an interesting issue with a Toshiba Satellite Model: S70t-B Laptop I bought 2nd-hand recently.

1. I can start the laptop normally and its boots into windows without issues.
However, as soon as I either restart, shutdown or try to put the laptop to sleep it will perform the action but the laptop won't turn off. The power button light on the keyboard stays on and fan stays on.

2. This also occurs when NOT in windows. (e.g. If I go into the BIOS and change a setting and then save and reboot the machine doesn't turn off)

3. I then have to remove the battery (and/or AC power adaptor) to shut the machine down.

4. When I then plug the battery and/or AC power adaptor in again the machine LED power light comes on however I have to wait for around 3-4 minutes before it will start up again. If I press the power button on the keyboard the white LED power light flashes once only and nothing happens.

5. In addition to this strange behaviour, the Date/time in the BIOS and windows loses time very slowly.

So, I'm trying to figure out what the single white power button flash means. I suspect this is a motherboard issue and possibly a power controller problem maybe? If anyone has any ideas please let me know. I'd like to see if it's a simple fix I can do myself.

This is what I've tried doing so far but it hasn't changed the behaviour described above:

- Reseating the Ram, removing/Checking the HDD
- Checking for overheating issues. CPU and GPU running at around 45-50 degrees. Don't think this is a problem. I have also removed the heatsink/fan and put new thermal paste on the CPU and GPU.
- Turned off all the sleep settings in windows
- Updated the system BIOS to version 5.20 (latest version)
- Changed the CMOS battery to a new one

My Specs are:

OS: Windows 10 Home 64-bit
16GB DDR3 1600Mhz RAM
Graphics: Intel HD 4600/AMD Radeon R9 M256X

I also have the following issue in Device Manager

Intel 8 Series/C220 Series USB EHCI -8C26 device cannot be started (Code 10)



Nov 26, 2017
Question from benjulie.jones : "Toshiba Satellite S70t-B doesn't shutdown or restart properly in WIndows or BIOS"

Hi. I have a strange problem with my Toshiba Satellite S70t-B laptop.

Whenever I restart, shutdown or attempt to go into sleep mode it will appear to perform the action but then the power button, fan and power LED lights continue to stay on and never turn off.

I then have to either disconnect the battery or pull out the AC Adaptor to actually turn the laptop off completely. This problem occurs even when I'm in the BIOS settings.
I've also noticed that sometimes the mouse won't appear in Windows or it might randomly freeze.
The date/time on the machine is also very very slowly losing time. I'll set it to the correct time, and then 10 minutes later it is showing 40-50 minutes slower. Very strange.

I've tried:

- Reseating/Removing the RAM, checking the HDD
- Changing the CMOS battery
- Upgrading the BIOS to Version 5.20 (from 1.10)
- Removing all internal components(HDD, DVD and testing it)
- Removed and cleaned heatsink/fan and reapplied thermal paste

It's like the signal to completely turn off or restart the laptop is not sent to the motherboard for some reason. I can successfully restart the laptop everytime this happens (although sometimes there is a delay in starting).

Any ideas what the cause might be?


Windows 10 Home
16GB DDR3L 1600Mhz RAM
Intel HD 4600/A9 Radeon M256x switchable graphics card