Toshiba Satellite Suddenly Running Slow

MIKE GWIN

Estimable
May 7, 2015
2
0
4,510
0
Hello everyone.

My Toshiba Satellite this week suddenly started to running slow.
I have defraged the HDD, changed the thermal paste, cleaned the cooler, scanned for virus, cleaned all the computer with Advanced System Care and CCleaner, formated te pc and it is still running slow. Do you have any idea for what might be the problem?

My specs:
Windows 7 64bits
CPU AMD A8-4500M with Radeon HD Graphics 1.90GHz
AMD Radeon HD 7640G + HD 7500/7600 Dual Graphics
8GB of RAM
500GB HDD

PS: My temps are:
CPU - 74º
GPU - 74º
Motherboard - 68º
 

MIKE GWIN

Estimable
May 7, 2015
2
0
4,510
0


No errors found on HDD and RAM. I have all the drivers updated, but it still does the same.

My thermal grease is Deep Cool Z3, is it good?

 

Alexis_4

Estimable
Oct 26, 2015
1
0
4,510
0
This happened to me. I called and they Walked me through the fix.
Turn off comp
Then after turned off hold the Power button 20 seconds. It'll turn on then off. Then hold down F2 and turn comp back on at same time then when the setting page pops up push F9 click yes then F10 and yes again. It helped me
 
Thread starter Similar threads Forum Replies Date
C Laptop Tech Support 2
MadFromTech Laptop Tech Support 1
C Laptop Tech Support 5
Eligijus Laptop Tech Support 1
Eligijus Laptop Tech Support 1
wolfluvr Laptop Tech Support 1
J Laptop Tech Support 3
A Laptop Tech Support 1
Bluemoon1502 Laptop Tech Support 1
G Laptop Tech Support 3
O Laptop Tech Support 5
D Laptop Tech Support 1
XVII Laptop Tech Support 0
L Laptop Tech Support 8
K Laptop Tech Support 1
S Laptop Tech Support 4
M Laptop Tech Support 2
M Laptop Tech Support 1
Q Laptop Tech Support 2
J Laptop Tech Support 1

ASK THE COMMUNITY