Toshiba Satellite Touchpad Stops Working

Status
Not open for further replies.

Marie_25

Prominent
Feb 9, 2017
1
0
510
0
I have a Toshiba Satellite L55 running Windows 10 Home that I typically use with an external mouse. However, from time to time I need to use the touchpad. When I first installed the external mouse, I was able to configure the touchpad so that it would be automatically disabled any time an external mouse was detected and it worked perfectly. However, for the last 3 years, the touchpad intermittently just disappears. When I look at the Device Manager, the only device there is the HID-compliant mouse, but the Synaptics Pointing Device (I think that was the name) is gone. In the past, I think I would just have to reinstall that driver but I can't find anything at the Toshiba site.

This is so frustrating since it's been an ongoing problem since the day I bought this laptop and it happens with no rhyme or reason. I've tried various solutions found on the web (combinations of F5, F9, and Fn) but none of them do anything.
 
Without the full info on your laptop I can only go so far... but try these ... http://support.toshiba.com/support/modelHome?freeText=1200005653&osId=26 If those aren't the right ones, find your system in this section of the site and locate the drivers for it.


1. Download the correct Synaptics Drivers for your system, but do not install yet.

2. Next download this troubleshooter: https://support.microsoft.com/en-us/kb/3073930

3. Run the troubleshooter. Click "Next" and then click "Hide updates."

a. If "ASUS - Other hardware - Asus Support Device" is listed, check the box
and press "next" until the troubleshooter is finished. Then proceed to step 7.)

b. If "ASUS - Other hardware - Asus Support Device" isn't listed, proceed to step 4.

4. Now go into "Device Manager" and uninstall the drivers for "Asus Support Device". It should be under "mice".

5. At this point you want to restart your computer. When the computer restarts, Windows will eventually try to re-download and install the drivers. This may not happen right away, sometimes it takes a while. Luckily you should be able to 'disable' the driver from the troubleshooter before that happens.

6. Again run the troubleshooter and the "Asus Support Device" should now pop up as an option. Select it and run through the troubleshooter.

7. If it's still there, uninstall "Asus Support Device" in device manager, under mice. Then return to step 4 and reboot.

8. Now you want to unzip the Synaptics file and run the setup.exe.

9. Once it is done, restart your computer again.

Now your trackpad options should correctly show up in the control panel "Mouse Options", and Windows won't replace the drivers anymore.
 

geldankat

Commendable
Jun 25, 2016
1
0
1,510
0
Hi Marie,

I have been having the exact same issue with my Toshiba Satellite S75t for a couple of years. I never knew what was causing it and in spite of trying all kinds of troubleshooting (reinstalling drivers, running various DSIM commands etc.) I could never fix it on demand and would just go back to using an external mouse until the touchpad functionality would magically return after some period of time. However I recently started seeing a pattern. I believe the issue has something to do with the incoming voltage to the laptop. (I'm NOT an electrical engineer so this is just a guess!)

I would normally have the laptop plugged into a power strip. One time when the touchpad was inoperable, I plugged the laptop directly into a wall outlet for some unknown reason and rebooted, I noticed that the touchpad was working again shortly after. Then at another time when I noticed I'd lost the touchpad again, I checked the power supply and found that the plug was pulled partially out of the wall socket. It was still getting power, because the battery wasn't draining but apparently there was something wonky about the incoming power supply. After I plugged it in completely and rebooted, I got the touchpad back again.

The last time I lost the touchpad, the laptop was securely plugged into the wall and rebooting didn't help. So I tried the following steps and managed to get the touchpad back again:
1. Shut the laptop down completely
2. Remove the battery and unplug the laptop
3. Press and hold power button for about 30 seconds (not sure if this is necessary)
4. Plug laptop back in (directly into a wall socket) but leave the battery out
5. Press power button to turn the laptop back on
6. When the Toshiba screen first shows up, press and hold power button again until laptop shuts down again (again, not sure if this is necessary. I just wanted to make sure it was completely shut down so it would cold boot)
7. Press again to start up (with the battery still out)
8. Allow it to boot up completely
9. Check Mouse setting (under Control Panel), or check Device Manager or run Function app to make sure touchpad is recognized again
10. After the system is fully booted up, put the battery back in and carry on!

Long story short, I'm thinking it may be some kind of glitch in how the touchpad is receiving power and when you run through this process to "reset" everything from an electrical standpoint, it comes back. It's worth a shot anyway. You definitely have my sympathy on this. The struggle is real! ;) Good luck!
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
ramseylacey24 Laptop Tech Support 1
G Laptop Tech Support 11
FracturedCode Laptop Tech Support 5
BenKnack2468 Laptop Tech Support 1
E Laptop Tech Support 2
A Laptop Tech Support 1
J Laptop Tech Support 2
raptormoonx Laptop Tech Support 5
M Laptop Tech Support 3
E Laptop Tech Support 10
J Laptop Tech Support 2
F Laptop Tech Support 3
A Laptop Tech Support 1
C Laptop Tech Support 1
C Laptop Tech Support 1
S Laptop Tech Support 2
M Laptop Tech Support 1
S Laptop Tech Support 5
J Laptop Tech Support 2
C Laptop Tech Support 99

Similar threads


ASK THE COMMUNITY