Unable to boot from a SSD fitted into optical drive

Jun 26, 2018
5
0
10
0
Laptop Details : Dell Inspiron 14RN4110 i3 processor

Attached a Kingston 120GB SSD in the DVD bay using a universal laptop caddy.

Fully Cloned all the existing partitions using a cloning software

Both the drives are shown up in the BIOS screen, but only the primary HDD is shown in the boot priority list.

I tried to move the HDD to a priority later than the CD/DVD drive ( actual SSD is not shown) , but system is not booting through the SSD.

Please advice. Thanks in advance
 

Lutfij

Splendid
Moderator
1| Forget that you cloned the previous installation drive + install the OS using a bootable USB/CD/DVD installer.
2| Rule out that the caddy is faulty by disconnecting the HDD and installing the OS on the SSD alone.
3| You might also want to see if there is a toggle switch at the side of your caddy(either internally next to the SATA connector or externally at the side of the caddy to the right or left). The toggle switch is for compatibility's sake.
 
Jun 26, 2018
5
0
10
0


Thanks for the quick reply .will check this out. I didnt see a switch in the caddy though
 
Jun 26, 2018
5
0
10
0


Image available here

 
Jun 26, 2018
5
0
10
0


Removing the hardrive on this model is bit complicated and thats one of the reason i wanted to put the additional drive into the optical drive bay.

I installed EasyBCD software and was able to change the boot sequence

With this I am able to boot it through the SSD itself and i can feel the improvement in the performance in boot time, apps load etc

Latest image of the disk management



Is it now safe to delete the OS partitions in the HDD and use it as a pure data drive ?

I would like to do that after few days of usage , once the ssd boot is stable.

Also will the performance be better if the i swap the drives , i can get it done thru a service person if its really worth.

Please suggest how can i take a backup of the OS partitions into a bootable USB etc to use in case of any failures

Thank you so much both of you for the responses

Cheers, Ganesh


 

SkyNetRising

Estimable
Jan 4, 2016
372
0
5,210
83
No. Your system will not boot, if you do that.

Your system still boots from bootloader on 500GB drive (partition with "System" in description).
Windows is being loaded from 120GB drive (partition with "Boot" in description). So that's a progress. But - drive letters are wrong. Normally you can't change drive letter for windows partition. To change them involves usage of regedit.
Run regedit;
Open HKEY_LOCAL_MACHINE\System\MountedDevices
Rename \DosDevices\C: to \DosDevices\E:
and rename \DosDevices\D: to \DosDevices\C:
Reboot your system and verify that "OS" partition on 120GB drive has drive letter C: and "Boot","Page File" in description.
Only after that you can format "OS" partition on 500GB drive. Do not touch "RECOVERY" partition on 500GB drive or your system will not boot anymore.
 
Jun 26, 2018
5
0
10
0


Thank you so much for the reply. will try this out and revert

I tried the same and it worked as you mentioned..

Latest disk mgmt. screen pic : http://tinypic.com/r/o52d7a/9

Thanks again for this.

 
Thread starter Similar threads Forum Replies Date
A Laptop Tech Support 3
V Laptop Tech Support 1
LifeIsAFairyTail93 Laptop Tech Support 1
A Laptop Tech Support 0
S Laptop Tech Support 0
rahulkumarbudhwani Laptop Tech Support 1
Y Laptop Tech Support 2
B Laptop Tech Support 5
T Laptop Tech Support 1
D Laptop Tech Support 8
K Laptop Tech Support 1
iFail101 Laptop Tech Support 5
Z Laptop Tech Support 4
R Laptop Tech Support 3
A Laptop Tech Support 1
O Laptop Tech Support 3
S Laptop Tech Support 1
A Laptop Tech Support 2
T Laptop Tech Support 1
T Laptop Tech Support 1

ASK THE COMMUNITY