Unknown Device on Toshiba laptop - Windows 10 v1709 will not install

HotCzech46

Estimable
Dec 26, 2015
5
0
4,510
0
I have a Toshiba Satellite M115 S3154 laptop running Windows 10. I get a message from Microsoft that I must update to version 1709 or in April I lose support. I have tried a dozen times. Gets to 33% and the install crashes and the system restores to prior version of windows.
Microsoft gave me the following error message last time:
OxC1900101-Ox30018
The installation failed in the First_Boot phase with an error during SYSPREP operations

I have searched for what could be wrong, including removing all devices I could and moving files off the laptop. I have over 30G of space available. Searching the Device Manager, I found an Unknown Device. No driver available on the internet or the Toshiba website. Laptop has newest Bios installed. In the device information it says
ACPI\TOS1901\2&DABA3FF&2
I tried disabling the device and would not work. No help.
I tried deleting it but it pops right back up when I reboot.
Any help would be appreciated.
 

HotCzech46

Estimable
Dec 26, 2015
5
0
4,510
0
Tried everything in that article. Did not work. I have tried installing 1709 at least 15 times now. It always kicks out when it hits 33%. It then automatically reboots and restores the old version. It is the lack of drivers that I am convinced is causing the problem and there are absolutely NO drivers available on the Toshiba site. They offer a Bios upgrade, which I have already done, and still no drivers for their internal devices.
 

HotCzech46

Estimable
Dec 26, 2015
5
0
4,510
0
The difficulty continues. I have tried uploading the update at least 20 times. Takes over an hour each time and you have to click on various options each time so if you leave, it takes longer. I have disabled about every device I could, one at a time, and run the update and every time it stalls on 33%, then restores the prior version. Sometimes I get the blue screen of death with the DPC_WATCHDOG_VIOLATION error shown. I have researched it, and think I finally at least know what the problem is.
I don't believe the Windows 10 update will work unless you have SATA AHCI activated on your machine.
The problem is that the Toshiba satellite does not give you an option in the BIOS to choose IDE/RAID/AHCI. The computer is using a SATA hard drive and the device manager shows under IDE ATA/ATAPI controllers devices for

ATA Channel 0
ATA Channel 1
Intel(R) 82801GBM/GHM (ICH7-M Family) Serial ATA Storage Controller - 27C4

All three of the devices show drivers provided by Microsoft.
As noted, when I boot into BIOS, there is no option to choose anything. There is an excellent article at
https://www.drivethelife.com/windows-10/enable-sata-ahci-mode-in-bios-on-windows-10.html
which details how one would go about adding the AHCI option into your BIOS. He used a Phoenix BIOS as an example and my system has a Phoenix BIOS. Regretfully, it changed nothing on my system. No AHCI mode.

I am convinced this is the reason for the failure of the update, and the reason for the DPC_WATCHDOG_VIOLATION error given.
Not sure where to go from here. Is the laptop toast? It has run Windows 10 successfully and well since Windows 10 first came out. I seldom use it, but really need it when I do. Hate to have to buy a new one.
 

ex_bubblehead

Honorable
Moderator
Did you even bother to explore any of the provided links? So far it would appear that you've blown off all help and are trying to wing it.

Start here: https://docs.microsoft.com/en-us/windows/deployment/upgrade/resolution-procedures#0xc1900101

0xC1900101

A frequently observed result code is 0xC1900101. This result code can be thrown at any stage of the upgrade process, with the exception of the downlevel phase. 0xC1900101 is a generic rollback code, and usually indicates that an incompatible driver is present. The incompatible driver can cause blue screens, system hangs, and unexpected reboots. Analysis of supplemental log files is often helpful, such as:

The minidump file: $Windows.~bt\Sources\Rollback\setupmem.dmp,
Event logs: $Windows.~bt\Sources\Rollback*.evtx
The device install log: $Windows.~bt\Sources\Rollback\setupapi\setupapi.dev.log

The device install log is particularly helpful if rollback occurs during the sysprep operation (extend code 0x30018). To resolve a rollback due to driver conflicts, try running setup using a minimal set of drivers and startup programs by performing a clean boot before initiating the upgrade process.
 

johnbl

Honorable
Nov 4, 2012
140
0
10,710
35
looking up the ACPI\TOS1901\2&DABA3FF&2 it might be that you have to run this utility as an admin
https://support.toshiba.com/support/viewContentDetail?contentId=4009381

maybe you have to remove the supervisor password before you do the update. Not sure



 

HotCzech46

Estimable
Dec 26, 2015
5
0
4,510
0
ex_bubblehead - Yes, I have viewed, studied, and tried everything (or almost everything) on each of the links. For example:
- I have not only turned off all antivirus programs, but have removed them. (Avast in particular)
- Turned off the firewall
- Incompatible driver - as noted, I went through the computer and disabled everything I could, one by one, running the update each time to see if removing that one would fix it. Did not help.
- tried installing it over both wireless and cable. As suggested, disabled the wireless card. Not only that, but I also created a USB disc, and disconnected all internet access, and tried running it that way. Did not help.
- removed every USB device, except when I disabled the touchpad on the laptop, I had to keep the usb mouse plugged in.
- ran sfc/scannow - ran it several times, especially after messing with the register as required by some of the links
- updated everything from Windows (except this current update) and updated BIOS to current version. Even tried some of the automatic driver upgrade programs but all I got was a load of viruses on my machine that I had to clean off.
- of course, before doing this, I ran Avast complete scan, and then clean files and cleaned the register with CCleaner.
- did not run the log and send separate file to Microsoft, since everytime I get the BSOD, it sends out the logs (or at least it says id does)
The above was everything on your first link.
For your second line:
- did everything in the quick fixes. Removed everything from the computed. I have no personal files left on it at all and removed all programs other than windows.
- I could not run setupdiag.exe - I have NET Framework 4.7 installed. Article says I need 4.6 and I guess that is why setupdiag.exe would not run.
- Troubleshooting - good info, but all it got me was that my error is occurring in the First Boot Phase
- error logs - spent some time trying to decipher these. There is one for each time I tried to load the upgrade. Per your note, they all have "Panther" in them somewhere. Some were not accessible. Not sure why. Bottom line is that there were a lot of error codes and they were not consistent. The last one had 0xC1800104 and several instances of -x800705BB. One before that was zero bytes. One before that had one error code of 0x000000b7 - failed to create Window PE rollback directory. I think this one had to do with the restore after the failure.
Note that the DC WATCHDOG VIOLATION did not show up in an error log but was shown on the BSOD message. That is the one that got me looking on the Microsoft site to see what it meant and led me to chasing down the AHCI issue and the lack of such choice on this laptop
The last item on your second link was to submit all this to Microsoft. I have not had good results in doing that, but prefer to submit it here or on MajorGeeks.
Your third link - this one dealt exclusively with the Ox30018 error code. It was good, but I have done every task mentioned there, including all the ones which are the same as in the first link you sent, plus disabling sound adapters in BIOS, running the DISM tool, using Media Creation to create the USB and running the upgrade from the USB, running the pnpclean registry hotfix. However, I did not try the registry key creation and modification they discussed. Just too much messing around in the registry, especially since I don't know how these would react with the other registry fixes.
So. No. I have ignored your advice (or I should say the advice given in the links you provided).
My last post was directed at the BSOD reference, which I had not seen before, and the discovery that AHCI could not be activated on this laptop. Trying to find out if others have had the same issue.

 
Jun 29, 2018
1
0
10
0



Can i ask which bios you are running in windows currently? I would ensure you are Not using bios version 5.1 as this has problems with wifi for one thing. It is possible to downgrade back to version 5.0 or even 1.7 of needed. I had to do this on windows 8.1 to get my wifi working again as 5.1 caused problems with mine.
 
Thread starter Similar threads Forum Replies Date
Jero_0001 Laptop Tech Support 1
A Laptop Tech Support 2
open2screens Laptop Tech Support 4
D Laptop Tech Support 4
J Laptop Tech Support 2
R Laptop Tech Support 1
C Laptop Tech Support 1
S Laptop Tech Support 1
H Laptop Tech Support 3
D Laptop Tech Support 1
M Laptop Tech Support 1
S Laptop Tech Support 7
A Laptop Tech Support 4
K Laptop Tech Support 3
A Laptop Tech Support 3
M Laptop Tech Support 6
M Laptop Tech Support 5
K Laptop Tech Support 5
B Laptop Tech Support 8
J Laptop Tech Support 1

ASK THE COMMUNITY