USB-device of Canon EOS 400D unrecognizable, will downloading and installing DPP RAW enable recognition of device?


Jun 4, 2012
Hi, the problem is as the title states, the device is detected but not recognized on my computer with Windows 7. It's a several year old camera but after a quick search I found that it works with DPP RAW photo-managing program (bildbehandlingsprogram in Swedish, not sure if exact translation). On a sidenote, I have an old driver on CD (at least 6 years old) that has been used previously with the Camera on an old computer with XP OS, I tried it with windows 7 and recieved the following error message:

1608: Unable to create InstallDriver instance

Return code: -2147024894

Upon clicking the only option box given "OK" which closed the message and opened up a new window with the options "Abort Installation" or "Troubleshoot". Troubleshoot gave me 4 possible solutions to this specific problem laid out in a nice readme file which guided me through the process. The readme file made no mention of OS later than XP though. There was no trouble in going through the solutions, but none of them worked, same error message appeared every time. Is this simply because the program is incompatible with windows 7? Or is there some way to make it work? Just curious, I would prefer to have more modern software. And if all this has no effect on whether the USB-device is recognizable It'd be nice to know actual solution to this. Cheers :)