Question Video Went Bad on Two TV's - Possible Bad HDMI - How Can I Fix It?

Sep 10, 2021
1
0
10
0
I have two 32" Televisions. One is a Samsung that is 6 years old and the other is a TCL Roku TV. Last week, the Roku TV video went blank. On all HDMI ports. It doesn't even show the ROKU menu. The audio still works. I had problems with the TV in the past, so I chalked it up to being a POS.

However, I hooked a Samsung TV up from another room to the same HDMI cable and DirectTV box. Within an hour, the exact same thing happened. I realized it was the same HDMI cable on both devices, so I have since removed the HDMI and also have not hooked up anything to the DirectTV box either.

So the question I have is whether anyone has heard of this happening and is there a simple fix? I've worked through the steps to reset both TV's listed online and nothing works. Is it simply replacing a part or is it not worth the fix?
 

hang-the-9

Titan
Moderator
Could be a bad cable causing a short, or the DirectTV port causing issues. Usually it causes glitches like random shutdowns not totally killing the TV. As far as what you need to do for them to work again, no way to really know till you try things, but I doubt it's as simple as soldering a new HDMI connector.
 
Thread starter Similar threads Forum Replies Date
G Streaming Video & TVs 4
Mrkaru Streaming Video & TVs 0
S Streaming Video & TVs 1
A Streaming Video & TVs 2
R Streaming Video & TVs 4
Weily Streaming Video & TVs 1
O Streaming Video & TVs 2
T Streaming Video & TVs 3
F Streaming Video & TVs 0
SophiaRichards Streaming Video & TVs 1
abully Streaming Video & TVs 1
R Streaming Video & TVs 0
S Streaming Video & TVs 2
rad07 Streaming Video & TVs 2
shaines Streaming Video & TVs 22
Pdbonlucas Streaming Video & TVs 3
Mordko Streaming Video & TVs 18
KatTech Streaming Video & TVs 3
T Streaming Video & TVs 8
AlanA76 Streaming Video & TVs 6

ASK THE COMMUNITY