Solved! Virus keeps me from opening anti-virus

May 11, 2018
2
0
10
0
I got a virus so I installed a malwarebytes
but every time I open it I get an error:

Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item.

Now I tried starting as administrator but I still have the error.
Did this virus just blocked my anti-virus?
Windows defender still works and made a full scan and the virus was excluded.

I really need help regarding this issue, how do I get back my "appropriate permissions"?
How can I delete these viruses If they excluded themselves? Do I need to download another anti-virus? or would I reinstall Windows 10 altogether?
 

th3p00r

Commendable
Sep 7, 2016
61
0
1,610
10
right click the start menu > run > msconfig > boot > Safemode > reboot then run malwarebyte.
if it still give you inappropriate permission error, try holding the shift key and right click it and run as administrator.
 
May 11, 2018
2
0
10
0


started safe mode and it said "Unable to connect the service"
tried it again with network safe mode still the same
I'm trying to fix it right now
 
Thread starter Similar threads Forum Replies Date
The KiWeeD Antivirus / Security / Privacy 1
D Antivirus / Security / Privacy 2
J Antivirus / Security / Privacy 5
F Antivirus / Security / Privacy 1
V Antivirus / Security / Privacy 1
T Antivirus / Security / Privacy 1
A Antivirus / Security / Privacy 6
D Antivirus / Security / Privacy 2
L Antivirus / Security / Privacy 3
H Antivirus / Security / Privacy 2
R Antivirus / Security / Privacy 1
E Antivirus / Security / Privacy 1
V Antivirus / Security / Privacy 2
B Antivirus / Security / Privacy 6
L Antivirus / Security / Privacy 2
C Antivirus / Security / Privacy 1
D Antivirus / Security / Privacy 5
O Antivirus / Security / Privacy 3
C Antivirus / Security / Privacy 11
S Antivirus / Security / Privacy 1

ASK THE COMMUNITY