Vizio XVT473SV SOUND WORKS NO PICTURE

Hckymech

Honorable
Jul 19, 2013
1
0
10,510
0
Hello all! I have a 47 " Vizio that is 26 months old that the white Vizio light comes on and the sound works but there is no picture? I'm pretty hand an can fix most things if I know what parts to get. Out of my league on this one. Can someone throw me a bone and let me know what part I need to purchase?

Thanks!
 

te100

Distinguished
Aug 8, 2004
248
0
18,910
35
take the back off and look for burn marks bulging or blown capacitors. It maybe the video card or the power supply for the screen.

I did this one time one of the boards in my 42" jvc was going out didnt know which one so I bought the same tv on ebay that had a busted screen got it for $100 free shipping replaced all the boards and now it works like a charm.
 

te100

Distinguished
Aug 8, 2004
248
0
18,910
35
take the back off and look for burn marks bulging or blown capacitors. It maybe the video card or the power supply for the screen.

I did this one time one of the boards in my 42" jvc was going out didnt know which one so I bought the same tv on ebay that had a busted screen got it for $100 free shipping replaced all the boards and now it works like a charm.
 

rmcel

Estimable
Aug 23, 2014
4
0
4,510
0


Did you ever fix this? I have the same problem now
 
Thread starter Similar threads Forum Replies Date
DayTrooperGW Streaming Video & TVs 1
C Streaming Video & TVs 0
D Streaming Video & TVs 0
joshuabgriffin Streaming Video & TVs 0
D Streaming Video & TVs 0
born2fly Streaming Video & TVs 0
C Streaming Video & TVs 0
C Streaming Video & TVs 1
John M. Streaming Video & TVs 0
J Streaming Video & TVs 1
A Streaming Video & TVs 5
Loyalty172 Streaming Video & TVs 1
brad336 Streaming Video & TVs 3
M Streaming Video & TVs 2
L Streaming Video & TVs 3
jovanboone Streaming Video & TVs 0
M Streaming Video & TVs 0
F Streaming Video & TVs 0
Hybrid Divide Streaming Video & TVs 0
M Streaming Video & TVs 2

ASK THE COMMUNITY