Weird nVidia GPU behavior on new laptop

surtur

Estimable
Jun 9, 2014
2
0
4,510
0

CPU: Intel Core Quad-Core i7-6500U (2.60 GHz)
RAM: 8 GB
GPU: Nvidia GeForce GTX 950Μ 4GB
Win 10


So, I got an HP Pavilion Gaming Laptop two days ago and I am having some weird problems with my GPU. First of all, I ran Heaven Benchmark with no AA and no Tesselation enabled and got a score around 700 which is bad considering I got around 850 on a laptop with GT 860M.

Then, I tried running some steam games and all I was getting was a white screen. I had all the latest drivers installed but removed them with DDU and re-installed. Still nothing. Afterwards, I disabled the onboard intel GPU. My games were now running but the benchmark produced errors and when I tried to open the nVidia control panel I got an error "You are not currently using a display attached to an nvidia gpu". What is happening? Is something wrong with the GPU?
 

Eximo

Distinguished
Herald
Two versions of the 860M. one is an older GK104 the other is a GM107 (750Ti), the GTX950M is also a GM107 but at a slower clock speed. So the difference may actually be accurate. Going up a generation, but down a model, is usually not an improvement, but closer to an equivalent.

Not sure about that second part. Sounds very strange.
 

Eximo

Distinguished
Herald
Two versions of the 860M. one is an older GK104 the other is a GM107 (750Ti), the GTX950M is also a GM107 but at a slower clock speed. So the difference may actually be accurate. Going up a generation, but down a model, is usually not an improvement, but closer to an equivalent.

Not sure about that second part. Sounds very strange.
 

CelicaGT

Honorable
Jul 22, 2013
89
0
10,610
11
If it is an Optimus setup then the dGPU output it routed through the iGPU. I've had some difficulties before with these. When you disabled the iGPU did you do it through the device manager, or another method? Often there is a bios switch or even a function key on the keyboard to force the use of the iGPU.
 

surtur

Estimable
Jun 9, 2014
2
0
4,510
0
Well things got a lot weirder. When integrated graphics are disabled games run on 1-2 FPS or crash. When both dedicated and integrated are enabled games run around 60 FPS..
 
Thread starter Similar threads Forum Replies Date
specuuu Laptop Tech Support 5
M Laptop Tech Support 4
Poxeh Laptop Tech Support 5
sm23 Laptop Tech Support 9
P Laptop Tech Support 6
Mythical22 Laptop Tech Support 3
J Laptop Tech Support 1
D Laptop Tech Support 2
A Laptop Tech Support 1
P Laptop Tech Support 1
bubesz94 Laptop Tech Support 1
ssam039 Laptop Tech Support 2
_dawn_chorus_ Laptop Tech Support 2
D Laptop Tech Support 1
P Laptop Tech Support 3
A Laptop Tech Support 1
C Laptop Tech Support 1
N Laptop Tech Support 1
N Laptop Tech Support 2
J Laptop Tech Support 1

ASK THE COMMUNITY