Windows 10 wrong keys

Ronsol

Estimable
Aug 12, 2015
2
0
4,510
0
After installing Windows 10 on both my laptop and PC, both computers exhibit the same problem in that if I press shift and the number 2 key, instead of @ coming up. " shows and vice versa when pushing shift and ' key @ comes up. How do I sort this out?
 

DrDanPhD

Estimable
Aug 6, 2015
3
0
4,520
1
From the sounds of it, the language has been set to United Kingdom during the installation process.

All that you'll need to do is open your settings and set the language to English (United States), then remove the former one.

This can be done either by using Cortana - search for 'region and language settings' - or from the quick action bar, all settings, time & language, region & language.

From there, click on 'add a language', select English, then English US, and that should install from Windows update. Following that, delete the previous.

Now, if the language is showing up as US English, it is possible to set the keyboard layout independently. Simply click on the language, then under keyboard add US QWERTY to the list; then - again - delete the previous.

That should put everything how it should be.
 

DrDanPhD

Estimable
Aug 6, 2015
3
0
4,520
1
From the sounds of it, the language has been set to United Kingdom during the installation process.

All that you'll need to do is open your settings and set the language to English (United States), then remove the former one.

This can be done either by using Cortana - search for 'region and language settings' - or from the quick action bar, all settings, time & language, region & language.

From there, click on 'add a language', select English, then English US, and that should install from Windows update. Following that, delete the previous.

Now, if the language is showing up as US English, it is possible to set the keyboard layout independently. Simply click on the language, then under keyboard add US QWERTY to the list; then - again - delete the previous.

That should put everything how it should be.
 

Ronsol

Estimable
Aug 12, 2015
2
0
4,510
0
Thank you Dr Dan for your prompt response and solution. For the record I have found that another way to change the language selection is to click on the right side of the task bar where, in my instance it says English, and in the window that opens, change the language choice to US English, which as you advised rectifies the problem.
 

sneezy2

Commendable
May 2, 2016
1
0
1,510
0
Thank you, thank you, thank you Ronsol! - your simple solution worked a treat. :) Thanks to you too, DrDanPhD for your helpful advice.
 
Thread starter Similar threads Forum Replies Date
S Laptop Tech Support 1
R Laptop Tech Support 3
C Laptop Tech Support 8
M Laptop Tech Support 1
C Laptop Tech Support 1
C Laptop Tech Support 1
S Laptop Tech Support 4
T Laptop Tech Support 2
Z Laptop Tech Support 1
N Laptop Tech Support 3
I Laptop Tech Support 2
J Laptop Tech Support 3
S Laptop Tech Support 2
L Laptop Tech Support 1
W Laptop Tech Support 1
R Laptop Tech Support 3
5 Laptop Tech Support 3
A Laptop Tech Support 13
M Laptop Tech Support 3
S Laptop Tech Support 1

ASK THE COMMUNITY