You must be logged in as an administrator

ftdsn244

Distinguished
Jan 9, 2010
36
0
18,580
0
I am trying to download the last of my drivers needed and I keep getting this error message. The problem is I am logged in as an admin. I even deleted the old user account and made a new user account to make sure I set it as Admin. but I am still getting this error message when trying to download.

Also I have downloaded other programs like Avast, Firefox, Ccleaner and had no problems but now I cannot download anything else without it saying there is an error. Thanks in advance for any help.
 

ftdsn244

Distinguished
Jan 9, 2010
36
0
18,580
0
Thanks guys.

Adams- I cleaned it with Avast and Malwarebytes and still did not work.

abekl- Yes tried rebooting. Still nothing

Ijack- when I right click I hit run as and the box pops up and I click the bubble underneath the current user that says The following user. This has 2 options. It has my log in user which I set as admin. Then it has another option that says admin on it. I try doing the admin option but it is asking me for password which I never set. I tried the password I used for my personal admin account but does not work. I tried leaving it blank and it says I cannot leave it blank. Is there some type of master password that get set on these? Because the only password I set up is for my admin account and it won't work for the account labeled admin under run as. Thanks
 

ftdsn244

Distinguished
Jan 9, 2010
36
0
18,580
0
Also another problem when I try downloading another driver. I believe it is either the sound driver or smbus drive I keep getting an error message saying "setup failed to launch installation engine, class not registered" Anyone know the problem on this? Thanks again
 

johnsonma

Distinguished
Jan 19, 2012
3
0
18,510
0
There is a hidden built-in Admin account in Windows 7 that has slightly elevated privileges when compared to a standard admin account that is set to have no password by default. Maybe try that when it gives you the two options. Also are you having any other issues with permissions on anything else besides the one driver?

You can activate this account by running your command prompt in administrator mode then typing:

net user administrator /active:yes

After that when you hit the login screen the hidden admin account will show up, you can try installing it then. After you are done I would deactivate it though.

net user administrator /active:no
 
Thread starter Similar threads Forum Replies Date
T Apps General Discussion 1
Y Apps General Discussion 1
V Apps General Discussion 1
J Apps General Discussion 9
N Apps General Discussion 1
F Apps General Discussion 1
Ordan Apps General Discussion 1
L Apps General Discussion 2
U Apps General Discussion 2
S Apps General Discussion 1
C Apps General Discussion 1
B Apps General Discussion 2
V Apps General Discussion 6
newbie12 Apps General Discussion 21
a cooperator Apps General Discussion 17
S Apps General Discussion 8
S Apps General Discussion 5
rfkhan7007 Apps General Discussion 1
D Apps General Discussion 3
S Apps General Discussion 1

ASK THE COMMUNITY