5.1 Surround rear speakers not playing sound

arama00218

Estimable
May 10, 2014
2
0
4,510
0
I just bought the Logitech z506 5.1 speaker system earlier today and I have connected all cables appropriately, the driver for my motherboard (MSI z87- g45) sound card has been downloaded and in the Realtek HD audio Manager, the side speakers act as the rear ones and play sound when they are tested but in windows the sound is not played from the rears.

I also tried some gaming to see if they work with battlefield 4, need for speed rivals, counter strike global offensive and the rear speakers worked.
I just need to find a way of making the rear speakers work when I'm playing music or watching videos even if they're not playing in 5.1 surround.

I have speaker fill enabled in Realtek Audio Manager and I have tested all the speakers in windows and in Realtek, they all work fine apart from the rears which only work in games.
 

MagicPants

Distinguished
Jun 16, 2006
87
0
18,610
6
The was a old shareware program designed to fix this, but I could never get it to work correctly. Two things work for me: 1 use xbmc as it has an option to expand the stereo, 2 get a creative card as they also include stereo expansion, you might be able to just install TruStudio and run that on your current hardware.
 

arama00218

Estimable
May 10, 2014
2
0
4,510
0


I can see how this could work but I don't think I would benefit from using xmbc as it would not extend the stereo on other programs.

my friend has the same system but I think the problem might be something called speaker fill in Realtek HD Audio Manager, when my friend checks the speaker fill box the rear speakers work perfectly but stop working when speaker fill is off. In my case speaker fill has no effect and the rear speakers only work when being tested or in games. If there is another possible solution I would be happy to try it out apart from getting a new sound card which I do not really want to do at the moment.

My friend's hardware is also different and he is using a gigabyte motherboard with older Realtek Software than me.

I was also not able to install Trustudio as my hardware was not compatible.
 

Marek_10

Commendable
Mar 24, 2016
1
0
1,510
0
Way I did it (I don't know how much it works yet) is to set it to 7.1, and then unticked the side speakers, when asked on the next page for optional speakers. Sound that was supposed to come from those, is transferred to front-side speakers, which is fine by me
 
Thread starter Similar threads Forum Replies Date
LostWorm Audio 1
SyncMasterBW Audio 2
E Audio 5
I Audio 1
B Audio 2
N Audio 2
G Audio 4
MrSalty Audio 11
B Audio 3
A Audio 2
S Audio 3
H Audio 28
T Audio 2
T Audio 4
C Audio 3
W Audio 2
S Audio 1
T Audio 1
F Audio 1
M Audio 4

ASK THE COMMUNITY