Access Denied even I am the Administrator and also Failed to change Ownership ( I am the Only Administrator )

Leon323

Estimable
Jul 3, 2015
3
0
4,510
0
( This is NOT the problem ) So, Recently I downloaded DOTA 2 from STEAM and when tried to run it gave an Update error. I looked for solutions and found one that is to delete a folder named "downloading" located in Steamapps folder But....

( The PROBLEM ) When i tried to delete it , It gave me that I need to provide Administrator permission to delete, So I clicked Continue and then it gave me Access Denied and saying that I need MY OWN PERMISSION ( My PC name and My name ) and says "try again" or "cancel". I watched several videos , Tried almost everything , Spent 4 hours trying to fix it but its still the same.

It keeps telling Access Denied whenever I try to change Ownership. However the Owner is still me ( My name and Administrator ) but still I can't delete that folder. Any Idea how to fix this?
 

Snipergod87

Distinguished
May 26, 2009
419
0
19,010
46
I have seen this before where it is stating you require permission from yourself to delete the file. Something I would try (wouldn't hurt) is running a chkdsk /f on the drive in question.

Also have you tried deleting the folder in safe mode, if that doesnt work you could resort to using a Linux Live USB drive.

What do the permissions say in the advanced tab of the security dialog
 

Leon323

Estimable
Jul 3, 2015
3
0
4,510
0
I can provide screenshots of almost everything. I just want to fix this problem permanently and not to have it in future again.

 

Snipergod87

Distinguished
May 26, 2009
419
0
19,010
46
I have seen this before where it is stating you require permission from yourself to delete the file. Something I would try (wouldn't hurt) is running a chkdsk /f on the drive in question.

Also have you tried deleting the folder in safe mode, if that doesnt work you could resort to using a Linux Live USB drive.

What do the permissions say in the advanced tab of the security dialog
 

Leon323

Estimable
Jul 3, 2015
3
0
4,510
0


Hi Snipergod87, Thank you for your time

So, I booted into safe mode and tried deleting and it worked successfully. Thank you so much for helping me out. I was a little freaked out as i was trying to fix this for the past 4 hours and didn't search on the forum for a question like this.

Thank you so much again and do you want me to delete the thread or leave it as it is? cuz there maybe more of this thread
 
Thread starter Similar threads Forum Replies Date
M Antivirus / Security / Privacy 2
7 Antivirus / Security / Privacy 1
M Antivirus / Security / Privacy 2
J Antivirus / Security / Privacy 4
G Antivirus / Security / Privacy 9
J Antivirus / Security / Privacy 1
S Antivirus / Security / Privacy 1
T Antivirus / Security / Privacy 7
C Antivirus / Security / Privacy 4
Y Antivirus / Security / Privacy 1
H Antivirus / Security / Privacy 1
A Antivirus / Security / Privacy 3
L Antivirus / Security / Privacy 7
A Antivirus / Security / Privacy 4
S Antivirus / Security / Privacy 1
P Antivirus / Security / Privacy 2
A Antivirus / Security / Privacy 2
A Antivirus / Security / Privacy 3
F Antivirus / Security / Privacy 5
Ajeeshreloaded Antivirus / Security / Privacy 1

ASK THE COMMUNITY