Acer 5742G Plugged in, no led. Power on/off loop --- [SOLVED]

Paul Varga

May 25, 2014

I have this Acer 5742G that stopped working earlier.

I have searched the forums but those fixes didn't seem to work and my situation is a bit different.

So what happened:

I was just browsing the interwebs (point being no heavy processing or games that could lead to overheating) and suddenly I'm faced with a white screen. The next thing I noticed was that the LEDs were blinking: The power button, the power AC led, and the battery led. I figured it would be best to force it to shut down (4 sec power button) since Ctrl + Shift + Esc or Ctrl + Alt + Del didn't seem to work.
Checked for temperature but nothing seemed suspicious. No overheating since my laptop ran at around 40 Celcius after replacing the grease a month ago.
I decided to power it up again but no LEDs were lit anymore so no go. The laptop was stuck as if it had its BIOS corrupted.

The indicators on the laptop are:

The LED on the Power button upper left corner from the keyboard.
The HDD activity LED to the right of the power button.
The plugged in AC LED bottom left
The battery (charging) LED to the right of the AC LED

What I did try:
1. Removed RAM. nothing
2. Switch slots. nothing
3. Remove HDD and DVD unit. nope

4. Put them all back in and put together a Crisis USB to reflash the bios (using WinCrisis and the 1.30 BIOS). So, removed battery and AC. Held power button for about 20 seconds. Stuck the USB in a port I had used before for the same thing. Held Fn + Esc while inserting the jack into the laptop. The two LED's flashed orange shortly (not the led on power buton, but the power led and the battery led). Continued holding Fn + Esc while pressing the power button. The power led lights blue as it should, the fan at full speed just like the last time I had to recover the BIOS. But this time no HDD light to indicate any activity. Shortly after, the power shut down, the LED's powered off, the fan stopped. (Tried a couple of times) So, again. Not working.

5. Another fix found on the interwebs led me to do the following. Nothing plugged in. Battery out. Held the power button for 20 seconds. Released. Inserted the battery back then held the power button and the battery indicator blinked, and finally inserted the AC jack while still holding the power button. Then released and the fan started spinning (not full speed as before). The power LED lit blue and the battery LED lit orange as it does while working. But no HDD activity. So now it powers on and stays like that about four seconds then powers off and on again in a loop. To get it out of the loop I held the power button as in a forced shutdown.

6. Also tried desoldering the battery, left the motherboard without power a few minutes then started without battery. The same happened. Soldered it back on with nothing different

The current situation is this:

I plug the AC into the laptop but there is no power indicator. The power led used to light blue while AC was present without powering on. But after pressing the Power button, the power indicator as well as the power button light blue and the laptop goes into the same power on/off loop.

Thank you.
Thread starter Similar threads Forum Replies Date
R Laptop Tech Support 2
Grainbox Laptop Tech Support 1
milkwiway Laptop Tech Support 1
M Laptop Tech Support 2
C Laptop Tech Support 1
pyro_isn_oob Laptop Tech Support 4
M Laptop Tech Support 1
F Laptop Tech Support 4
H Laptop Tech Support 1
anbu13 Laptop Tech Support 4
anbu13 Laptop Tech Support 2
A Laptop Tech Support 4
S Laptop Tech Support 1
MrSefyou Laptop Tech Support 4
Genesis Mallari Laptop Tech Support 6
P Laptop Tech Support 1
P Laptop Tech Support 7
J Laptop Tech Support 3
J Laptop Tech Support 4
U Laptop Tech Support 5