Acer Aspire V3-772G with WIN10 default boot device missing

Vojta_1

Commendable
Feb 25, 2016
2
0
1,510
0
Hello, my 2 years old, out of warranty, Acer Aspire V3-772G with WIN10 is giving me a message ‘default boot device missing’.
I tried to take out the battery for a few seconds, take out the HDD and gently clean the inside of the laptop as well as the HDD from dust. I have also followed up on a thread where somebody with the same error but on WIN8 and a different Acer laptop was told to download the BIOS install file (isST2212.exe), Create a recovery drive and run it on a USB drive, change the Bios to Legacy Boot, move the USB HDD as the first boot device and end up in a WIN8 recovery console. I then went into the advanced options and into the command prompt where I went to D:/isST2212.exe … A new window titled InsydeFlash V5.37 pops up saying that my current BIOS ID is: Aspire V3-772 version: V1.15
And the New BIOS ID is: Storm2 version V2.12

Here I get an error that says the following: This BIOS is not for your Notebook PC. The version of ROM file is not newer than that of BIOS.

I Went on www.acer.com/ac/en/US/content/drivers where I looked onto Acer Aspire V3-772G BIOS drivers and the newest one is V1.15 which is the one I already have.

A LOT depends on me getting back into the desktop and backing up files that are in the laptop. I only need an hour more with it, PLEASE HELP, its serious.
 
Thread starter Similar threads Forum Replies Date
V Laptop Tech Support 1
J Laptop Tech Support 0
R Laptop Tech Support 0
A Laptop Tech Support 0
dietherdeyv Laptop Tech Support 0
Miizuki1512 Laptop Tech Support 0
Kjlaptop Laptop Tech Support 0
nnrbrtsn Laptop Tech Support 0
lyb Laptop Tech Support 1
ronaldo999 Laptop Tech Support 1
J Laptop Tech Support 2
SDHartyChalL Laptop Tech Support 4
M Laptop Tech Support 0
X Laptop Tech Support 1
GogetaBlue42 Laptop Tech Support 1
bbjlfvr Laptop Tech Support 2
A Laptop Tech Support 3
C Laptop Tech Support 1
I Laptop Tech Support 1
S Laptop Tech Support 3

ASK THE COMMUNITY