Solved! Android Tablet keeps freezing and rebooting even after Hard Rebooting


May 24, 2018
So I have a DragonTouch x10 tablet. For a while it has had a virus, I knew by the way it would constantly shut off and all of my apps would crash.

I successfully (at least i thought so) factory rebooted erasing everything from my tablet believing everything will be okay now, so i have been told BUT my tablet freezes even faster than it did before the reboot.

If I open ANY of my apps or settings it immediately freezes up and restarts itself before I can do anything. Plus it seems to only be triggered when connected to the internet.

Is there something I can do to fix this or am I out of luck???

And again yes, I have hard rebooted; factory rebooted either or I have done it already multiple times.
So you "Hard Reset" (a reboot is just turning off and back on) the tablet, which wipes everything from the device, even the OS, and then allowed it reinstall itself? If that is the case, and then you redownloaded and installed any apps, then one of them would be the problem. If it is software that is at issue, then starting up the tablet in "Safe Mode" should allow for it to stay loaded and not reboot. Granted in that mode you can't access most apps, it is a restricted mode, but if it works fine in it, then you need to get rid of whatever app or item is the cause.

Now if you didn't completely reset it, as stated above, and only did the type of reset that tries to keep some of your stuff on the tablet, then that would not have removed any problem app, virus, etc. In that case you would have to do a true "Hard Reset" to get it back to what it was when it was originally made.

Now if you did do the full on "Hard Reset" and the "Safe Mode" either doesn't load or you still have the freezing in that mode, then it may well be a hardware issue and not a software one.

I am including below the info on getting into "Safe Mode" and also the correct "Hard Reset" info. Just in case you didn't do the full erase.

To get into "Safe Mode" please do the following.

1. First turn off the tablet.

2. Next press and hold "Power" until you see the manufacturers logo on the screen, then release the power button.

3. "Quickly" press "Volume Down" and hold it for few seconds until you see the message "Safe mode: ON" or something similar.

4. If you wanted disable it, simply repeat the steps above, and you should see "Safe Mode: OFF" rather than on.

NOTE: Doing this will clear 'all' the data on your tablet, so it is suggested you not choose this option unless you have to, or aren't worried about losing anything on the device.

Be sure you back up any data you want to keep, to a computer or cloud account, before doing the reset.

To "Hard Reset" the tablet...

1. Make sure that the tablet is actually powered off.

2. Remove your SD card, if there is one in the device.

3. Press the "Power" and the "Volume Up" buttons, together, until you see the start-up logo on the screen.

4. Once you can see the logo, release the buttons and allow the device to enter the "System Recovery Mode".

5. Next use "Volume Down" button to get to the "wipe data/factory reset" option When in recovery mode the "Volume Up" and "Volume Down" buttons are how to can navigate and highlight what option you need.

6. Once you have selected the "wipe data/factory reset", press the "Power" button to select that option.

7. On the following screen, repeatedly press the "Volume Down" button until the "Yes - delete all user data" option is what is selected.

8. Then press the "Power" button to hard reset the tablet.

9. If you took your SD card out in step 2, when the device is up and running again, reinsert the SD card.


May 24, 2018

Thank you, from what you have said I think it might be a software issue. I did everything you suggested and it works perfectly fine when NOT connected to the wifi but as soon as I connect it, it freezes and reboots itself repeatedly until I turn the wifi off again.
Therefore I'm unable to download or use any of my apps since wifi is needed for that.
Then there is probably something on the device that is causing this. Something either you installed (bad app) or something that got installed with something else (virus, malware, etc.). Try checking the device for malware and viruses. If that turns up nothing. You may want to do a full on hard reset and then try using the WiFi prior to installing anything else. If it works OK, then you know it is one of the apps you install. Alas, the only way to check then is to go through them one at a time, installing one and then trying to access the internet. Over and over until you find the problem app.


May 24, 2018

Thank you, I uninstalled and disabled all apps and it seems to run well even when connected to wifi but when I enabled Google Play Services to add an account it freezes every time. So I believe Google Play Services is my culprit. I've tried force stopping it and clearing the cache and data multiple times but it freezes still when trying to add or make a new account. Any suggestions?
Thread starter Similar threads Forum Replies Date
Cyber_Akuma Android Tablets 0
E Android Tablets 4
johnf52 Android Tablets 1
M Android Tablets 1
M Android Tablets 1
J Android Tablets 0
J Android Tablets 6
P Android Tablets 0
snailmail26 Android Tablets 3
scwolves10 Android Tablets 5
Meadow36 Android Tablets 3
D Android Tablets 4
S Android Tablets 1
alphacoyle Android Tablets 1
Sia111 Android Tablets 6
Xaibior Android Tablets 1
Ayefee Android Tablets 1
D Android Tablets 2
P Android Tablets 1
C Android Tablets 1
Similar threads
Question Suggestions for a budget Android Tablet that is not an Amazon tablet
Question Options to get Wired Ethernet on my Samsung Tab
Solved! I have a Cambridge Sciences tablet that is stuck showing the word Android at boot up.
Question Fusion 5 F104v2 Android Tablet Not powering up past Fusion logo
Question How can an article titled best android tablets....have the top TWO contenders both say 'underwhelming performence'. And not list anything about CPU,
Question Searching for a 7" tablet that runs modern android
Solved! New Android Tablet, 500GB available storage, can only add 10GB, won't take any more
Question Android 10 Tablet 512gb with 129gb factory system used??
Question Looking for an android tablet with a removable battery that can be charged externally
Question RCA Tablet stuck in boot loop after factory reset
Solved! I have an Android tablet sm-t350. I'm looking for the best app to align my device with the sky.
Question Using android tablet as digital signage
Question Stolen Android Tablets in-the-box
Solved! I have android tablet/music player combo stays plugged in, is it ok to just leave it on when not in use?
Solved! Need Help, Android tablet stuck in loading screen
Solved! Ds4 isnt connecting to ps4 after using it in my android tablet
Question I have the rca android tablet.. I reset due to forgotten pin.. I still cannot get in with my linked google account
Question I need an Android tablet, preferably 7" class with 2 simultaneous USB connections
Android tablet freezes
Tablet cones on but freezes on android screen