ASUS M50SV-A1 charging port issue please help

Diego Ace

Estimable
Jul 9, 2015
1
0
4,510
0
Hi, a few weeks ago, my laptop released some smoke and the smell of burnt plastic. I didn't shut down to prevent overheating like other laptops are known to do. I unplugged it and let it cool for 2 hours and tried to reboot. The laptop booted up like nothing happened except I noticed that it would not charge. So I ordered a new charger from ebay and it still did not charge. Before all this happened, I would have to wiggle the port to get it to work and now that does not seem to work with the new or old charger. This leads me to think that the port is burnt? Any ideas what it could be and is it fixable? Thanks

*if you have questions to help you understand please ask*
 
Looks like you have damaged the internal components inside the laptop associated with the charging circuit, and will therefore need to return it to a repair facility. It looks like it is an easy fix, as your battery still boots up the laptop and it is otherwise ok.

In the meantime DONT drain the battery completely.
 
Thread starter Similar threads Forum Replies Date
T Laptop Tech Support 2
hsde Laptop Tech Support 7
L Laptop Tech Support 0
Silent_ Laptop Tech Support 0
R Laptop Tech Support 0
R Laptop Tech Support 0
K Laptop Tech Support 2
A Laptop Tech Support 2
A Laptop Tech Support 1
J Laptop Tech Support 1
D Laptop Tech Support 8
AG95 Laptop Tech Support 5
Nategreg Laptop Tech Support 0
maybeits_jack Laptop Tech Support 2
Neon The (Anthro) Umbreon Laptop Tech Support 3
Arkayne Laptop Tech Support 1
charliesfrt Laptop Tech Support 0
J Laptop Tech Support 2
N Laptop Tech Support 1
insaneX99 Laptop Tech Support 1

ASK THE COMMUNITY