Solved! Asus UX303UA: only works on AC power

Jun 12, 2019
Laptop battery had no problems a few days ago. Was using battery and left to sleep for 15 mins then returned and it would not turn on until charger was plugged in. The battery reads 82% charge even after hours of charging, upon plugging charger out, the laptop immediately shuts down.

Using the battery on both Ubuntu 18 and Windows 10 Home, works on neither. Also does not work when entering setup. Both OS's were installed very recently.

There was a rattle inside the laptop last week, opened it up and it was the network card's loose wire which was fixed. I worked fine after this no problem.

The laptop is a refurbished model with the warranty just expired.

I think its a broken battery or power management circuit, how can I debug this?
Sounds like you just need a new battery to me. They will often give a false percentage reading when they are going bad. You may never have noticed it before due to this. Especially if you keep it plugged in a lot.