ASUS X202E amber light in 5 seconds when you plug in. No power, can't turn on.

Enharous

Estimable
Nov 30, 2015
1
0
4,510
0
My Asus x202e was dead for two weeks already and I cant figure out what is the problem. I tried my battery in other unit with exactly same model and works fine.

When I plug the charger amberlight lit up but will light out after 3-5 seconds.
 
Hi,

Have you also tried the charger of the other laptop with your laptop that is currently not booting up? If it will work do try these troubleshooting steps that may help.
- Reseat the RAM, take them all off for couple of seconds the put them back in making sure that they are all seated properly then see if it will boot up.
- If these will not work the problem may lie on the motherboard of your laptop and if its still covered by the factory warranty do contact Asus support for a repair.
 
Hi,

Have you also tried the charger of the other laptop with your laptop that is currently not booting up? If it will work do try these troubleshooting steps that may help.
- Reseat the RAM, take them all off for couple of seconds the put them back in making sure that they are all seated properly then see if it will boot up.
- If these will not work the problem may lie on the motherboard of your laptop and if its still covered by the factory warranty do contact Asus support for a repair.
 
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 4
C Laptop Tech Support 1
P Laptop Tech Support 1
M Laptop Tech Support 1
R Laptop Tech Support 1
B Laptop Tech Support 1
J Laptop Tech Support 1
S Laptop Tech Support 1
H Laptop Tech Support 1
A Laptop Tech Support 1
R Laptop Tech Support 2
T Laptop Tech Support 1
R Laptop Tech Support 2
G Laptop Tech Support 2
M Laptop Tech Support 2
J Laptop Tech Support 2
C Laptop Tech Support 1
R Laptop Tech Support 6
T Laptop Tech Support 5
S Laptop Tech Support 8

ASK THE COMMUNITY