ASUS X202E won't boot up after cleaning.

Jaimetud

Estimable
Nov 23, 2015
2
0
4,510
0
I just got done doing a cleaning of my laptop because the fan was rattling. I followed the visual instructions laid out in this video:
https://www.youtube.com/watch?v=Lqx0-g3URiI

Only instead of a brush, I used a can of compressed air to blow the dust out. The fan still rattles, but that's not the problem now. Problem is, I can no longer boot this thing up. I put everything back on in it's rightful place and all, but now the thing won't boot up. The LED lights on the keyboard come up and the fan spins up, so I don't know what's going on. Any help would be greatly appreciated!
 
Hi,

It's possible that it's booting up but not displaying anything on the screen.
- Connect an external monitor and see if you'll see any display from it because if you do the problem may lie on the cable that connects the display to the motherboard.
- Try to reseat the connection making sure that it's connected properly.
- If it doesn't work reseat the RAM, take them all off for couple of seconds then put them back in making sure that it's seated properly.
- Lastly, just retrace all the steps you did to tare the laptop up.
 

Jaimetud

Estimable
Nov 23, 2015
2
0
4,510
0


The First two options didn't work. How do I locate the RAM on the board to reseat it?
 
Thread starter Similar threads Forum Replies Date
A Laptop Tech Support 1
Arom_pd Laptop Tech Support 2
B Laptop Tech Support 1
D Laptop Tech Support 3
F Laptop Tech Support 4
K Laptop Tech Support 1
B Laptop Tech Support 9
K Laptop Tech Support 1
J Laptop Tech Support 9
L Laptop Tech Support 2
J Laptop Tech Support 1
T Laptop Tech Support 1
R Laptop Tech Support 2
G Laptop Tech Support 2
M Laptop Tech Support 2
E Laptop Tech Support 1
C Laptop Tech Support 1
R Laptop Tech Support 6
T Laptop Tech Support 5
S Laptop Tech Support 8

ASK THE COMMUNITY