base gone on speaker

lahern

Honorable
May 8, 2013
3
0
10,510
0
Hi, I have an Img speaker with built in amp I use to connect to an ipod for classes tonight the base is not working but the treble is there is also a smell of something burning from the speaker does anyone know what this could be? please help I'm clueless
 

groundrat

Honorable
Dec 11, 2012
67
0
10,610
9
Depending on how it smells it could be any number of things. Formaldehyde is usually a cap. Burnt dog crap is a resistor. A hot electronics smell that leaves a metallic taste in your mouth is usually a choke.

If you can see the bass speaker cone, is it intact? If so it’s probably the amp or a bit of circuitry that is made to burn out to protect the speaker.

Basically, those units are not made to be repaired, just replaced. You could look into repairing it, but it will cost you more in parts and your time than it would to just get a new one. If you have a soldering iron, a DMM or a O’Scope I can talk you through it.

If you don’t know what those things are, buy a new one.
 

lahern

Honorable
May 8, 2013
3
0
10,510
0


 

lahern

Honorable
May 8, 2013
3
0
10,510
0
Thanks for the info, I have no idea what any of those are, could you tell me what would have caused this to happen? I had it connected to an Ipod and the volume base etc wouldn't have been at its highest or anything, its only a couple of months old would I have any comeback from the shop I bought it from or did I cause it somehow?
 

groundrat

Honorable
Dec 11, 2012
67
0
10,610
9
Without looking at it I couldn't hope to tell what did it. Since you didn't overdrive it most probably it was a power surge. If it is still under warrenty you might want to give a return a try.
 

ASK THE COMMUNITY

TRENDING THREADS