Blue Snowball mic not showing up anywhere

Daniel543M

Honorable
Dec 26, 2013
5
0
10,510
0
Hi there,
My brand new Blue Snowball microphone just arrived and I'm trying to set it up but my PC does not seem to recognize it.

I plugged it in and the red LED light turned on but the mic isn't showing up in recording devices, nor is it showing up anywhere in Device Manager.

More info:
- Using Windows 7 (and mic is compatible with Windows 7).
- The cable at the mic end is the right way.
- The cable at the USB end is connected into a USB 2.0 port (not a hub)
- The port is fully functional.
- Mic isn't recognized in any port.
- There are no drivers for this mic as it is plug'n'play.
- There are no other computers around for me to test the mic in.
- In device manager, there are no devices with a exclamation mark.
- I have tried restarting, disconnecting and reconnecting the mic, different ports and downloading & installing ASIO4ALL.

Any help is appreciated. I really need to fix this.

Thanks
 

monkey4sale

Estimable
Apr 20, 2015
6
0
4,510
0
Somethings probably up with the device itself. I had a Blue Yeti Mic and it was most definitely just a plug and play process, entirely hassle free in windows 7. Sounds like you have covered most angles to confirm the issue is with the mic itself....APART from trying it on another PC.... I would definitely try this before perhaps returning the Mic...if you can? Have you checked that your soundcard drivers are up to date?

Also

http://windows.microsoft.com/en-gb/windows7/open-the-hardware-and-devices-troubleshooter

But to me is sounds like an issue with the Mic..
 

Daniel543M

Honorable
Dec 26, 2013
5
0
10,510
0


Yeah I also think it's the mic now. I tried connecting it to a mates laptop and the same thing happened. That is, nothing happened; it didn't get recognized on the laptop either.

I think I'll be sending it back
 

monkey4sale

Estimable
Apr 20, 2015
6
0
4,510
0
sorry to hear that. But I think its your only option as we have tried everything else and the fact that the mic isn't working on another system pretty much confirms that it is faulty.
 

Misqwato

Prominent
Jun 11, 2017
1
0
510
0


Going on device manger and clicking hidden devices does not work. He doesn't know what hes doing
 

monkey4sale

Estimable
Apr 20, 2015
6
0
4,510
0


?? This is a very old thread... who does not know what they are doing exactly??

 
Thread starter Similar threads Forum Replies Date
KingOfTheFort Audio 1
medinad92 Audio 0
kaosity Audio 1
R Audio 1
E Audio 1
M Audio 0
0 Audio 1
M Audio 2
Z Audio 1
J Audio 4
S Audio 3
bbeennyy1000 Audio 2
P Audio 2
F Audio 2
L Audio 1
N Audio 1
N Audio 1
H Audio 4
X Audio 4
S Audio 1

ASK THE COMMUNITY