Blue Yeti permanent mute help me please

tsuki.no.fuyumi

Prominent
Dec 20, 2017
3
0
510
0
Hi, my Blue Yeti was working perfectly up until two days ago when I accidentally pressed the mute button while plugging the cable into my mic, but when I turned off mute, it still wasn't recording my voice. In other words, my mute button stopped working and my voice isn't being detected, but I can still hear my computer through the earphones connected to my Blue Yeti and my computer still recognizes the Blue Yeti as an input and output source. I have no idea how to fix this and I am not sure what exactly is wrong with it either...
Thank so much in advance!
p.s. I contacted Blue for support but they still haven't responded and it's been two days. I don't know what else to do ):
 

tsuki.no.fuyumi

Prominent
Dec 20, 2017
3
0
510
0


I've tried it on both Windows and Mac computers, and I've fiddled with settings on both to no avail, so it seems to be following the Yeti ://
 

Ralston18

Splendid
Moderator
Failed or defective mute button....

Any warranty left?

Continue to press Blue for support via chats, emails, etc..

Document your correspondence to keep a record of any promises or requirements to obtain a refund or replacement - if applicable.

Hopefully you will be eligible for one or the other.

 

tsuki.no.fuyumi

Prominent
Dec 20, 2017
3
0
510
0


That's what I'm thinking now too ): and no, it's past the warranty date unfortunately...
I'll definitely keep trying to contact Blue. Thanks for trying though!
 
Thread starter Similar threads Forum Replies Date
phi303 Audio 8
B Audio 2

ASK THE COMMUNITY