Broke something in the process of taking the video cable out of the screen. Need urgent help!

Status
Not open for further replies.

TheJakeHehe

Commendable
Feb 5, 2017
5
0
1,510
0
Hello,


I have a Dell Latitude e6400 laptop, and I got a problem with it. The problem is that I had to take the video cable out of the screen and then put it back for a second. Thing is, that all I see now Is a very dark screen and there's a very, very dim dell logo. I think I broke something in the process of taking it apart and then putting it back , here's a picture of what I think is the problem(you can actually see the broken cable in the connection) : http://oi65.tinypic.com/f1yzbk.jpg



Do I need to replace something? If so, how can I do it?
EDIT: Inverter has burned out. All I see are the last numbers on a sticker:

...60000600(first line)
....D091.00 LF(second line)
....002621-O(or Q)1L0(third line)

Can someone get me the inverter I need? I dont know how to search for it.

The details of screen are: LP141WX5 14.1" WXGA (TL)(C1) LG Display
 

Petrossa

Honorable
Jan 30, 2014
176
0
10,910
61
That cable looks good. Just lift the connector and slide it in, then press it down again on the cable.
From what you describe, it would appear that the backlight on your panel has stopped working.
If inserting the cable correctly gives you no joy, you will have to replace the panel itself.
 

TheJakeHehe

Commendable
Feb 5, 2017
5
0
1,510
0


I think the tip of the cable has broken and is now inside of the inverter connection - I also think I need to take that out somehow? I took it to an IT guy and he told me that it is the inverter that needs a replacement. Im also worried that once the tip of the backlight connector cable has broke off, you cannot use it again?


Also: look at it again - maybe you now understand what I mean by maybe has "broken off"; http://imgur.com/a/rY6hH (there is a piece of cable sticking out of the connection)
 

mjslakeridge

Honorable
Mar 6, 2013
324
0
11,260
56
Although your picture isn't the clearest, I don't think you broke off the end of the cable. What appears to be sticking out of the connection may be some insulating strip or a spacer. Can you push it back in so it is flush with the front of the connection and then re-insert the cable.
 

TheJakeHehe

Commendable
Feb 5, 2017
5
0
1,510
0


Will try doing that - thanks for the suggestion, I will get the laptop tomorrow and then I can try.
 

TheJakeHehe

Commendable
Feb 5, 2017
5
0
1,510
0
The inverter itself has burned out. I dont know how to replace it, there isn't really any part number or something like that. Any help would be appreciated!
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
P Laptop General Discussion 1
A Laptop General Discussion 2
K Laptop General Discussion 2
R Laptop General Discussion 3
N Laptop General Discussion 2
J Laptop General Discussion 2
B Laptop General Discussion 2
G Laptop General Discussion 4
L Laptop General Discussion 5
J Laptop General Discussion 1
MySeaGateIsDown Laptop General Discussion 2
T Laptop General Discussion 1
N Laptop General Discussion 2
A Laptop General Discussion 1
K Laptop General Discussion 2
J Laptop General Discussion 1
N Laptop General Discussion 1
O Laptop General Discussion 7
G Laptop General Discussion 2
B Laptop General Discussion 1

ASK THE COMMUNITY

TRENDING THREADS