Cant find ASUS AI Suite 3 download link ?

Zoftare

Estimable
Dec 9, 2014
5
0
4,510
0
I had it when i factory restarted the computer but then when i try to use Asus mx suit i cant use the video or asus music maker .Then i seacrhed for 'ASUS AI Suite' or ASUS in the computer nothing as AI Suit found the i tried to find a down load link for it but dont find any. Help ?:??:
 

Larry_3

Estimable
Aug 29, 2015
3
0
4,510
0


I can't find it either. I found that page before I came here and it's not there. I tried searching their site as well but can only find ver. 2. I've had a lot of trouble finding anything on ASUS site beyond drivers or utilities matched to the MB. If I knew what MB shipped with it I could do it that way.. I'll have to find out.
 

englee1

Commendable
Sep 22, 2016
3
0
1,510
0
http://www.asus.com/Motherboards/Z97A/HelpDesk_Download/

Select your OS from the list. Then scroll down & expand the "utilities" section.
You should see it there.

This is the version for my M/B Z97-A
 

Larry_3

Estimable
Aug 29, 2015
3
0
4,510
0


Thanks for looking for it, I do appreciate helpful people. I ended up switching my ASUS mobo for an ASRock 990fx. Thank you just the same.
 

ShadyJ911

Prominent
Mar 15, 2017
1
0
510
0


You're trying to download a MB utility without knowing what MB you have?
SMDH at the stupidity.
 

Larry_3

Estimable
Aug 29, 2015
3
0
4,510
0


Before calling someone stupid you should check your own head. I've known what mobo I've had since I bought it, as with every part in my pc. I was looking for an updated version of the software, but found later it won't just work with any ASUS board, including mine. It's also difficult to find without entering a board model that it's packaged with, hence the replies that were actually helpful.. BTW, the post is 3 1/2 months old, and back then I said 1) " If I knew what MB shipped with it (the software)", ...not "if I knew what mobo I had" and 2) That I no longer cared about it since I got a new non-ASUS mobo (and yes, I know what board it is, since I posted it 3 months ago). Thanks.
 

drsamanthacarter

Prominent
Jan 5, 2018
1
0
510
0
It is WAY down the list under Utilities. For my ROG HERO IX it is currently 23rd on the list.
Goto the list, expand all then search (Edit/Find in Firefox) for "Suite"
It is called -
Version V1.01.56 2017/01/05 200.16 MBytes
AISuite3
 

mobinfaruque51

Prominent
Jan 8, 2018
1
0
510
0
How i solve this was by downloading cpuid hw moniter which told me my motherboard model and then i typed it in to the search. Once i enter it, a drop down menu appeared and then selected my mobo and click on ''Driver & Tools'' from there its easy pick your os using the drop down menu and scroll down to ''Utilities'' and check if it says Alsuite 3 in the description and Download!

hope it helped and gl
 

mash64

Prominent
Jan 23, 2018
1
0
510
0
The problem is that the Drivers & Downloads page of ASUS is very poorly maintained / updated.
It is very dependant on which motherboard you have selected on this page, as to your ability to find the latest software you need.
You may find all your latest drivers and software for the very popular motherboards, but for the less popular motherboards a lot of related software just isn't listed, or is not updated.

For those people who are calling people with this problem "idiots" or "stupid", i suggest starting the download page by selecting the motherboard and OS of the people who reported the problem and THEN see if you can find it. Instead of selecting your own motherboard, and looking at the world from only your own perspective.

I suppose you could search for your software by selecting on of the popular motherboards, but then, how do you know if the software you're downloading is suitable for your own motherboard, and won't do any harm by running it?
I decided not to take the risk and contacted ASUS technical support. I suggest you do the same.
 
Mar 8, 2018
1
0
10
0


After I select my OS nothing happens at all
 

raiod1478

Prominent
Aug 13, 2017
1
0
510
0


Disable adblock or/and ghostery, or any other blocking program/addon you have. Then go to that page, refresh and select os again. That solved it for me.
 
Sep 25, 2018
1
0
10
0


i used another browser
 

ASK THE COMMUNITY