Question Clevo NH57AF1 already ruined?

Nov 25, 2021
2
0
10
0
Hi,
So I bought the Laptop mentioned in the title a few month ago and must say that it’s a really great machine, up to all tasks until today:
While editing a textfile, the screen suddenly turned black. I had to shut it down via holding the power button cause no other input would work. When trying to restart, the screen remained black, after a while the fans would spool up and another short while later, it shut down on its own.

So I pull the cabel and battery and let everything sit for a while, in that time I found that FN+D is the CMOS-Reset shortcut for clevos, so I figured I’ll try that, but didn’t even get that far...

Put the power supply back on and hit the power switch, LEDs in front light up one last time and that’s it. No sign of life, with or without battery. Pressing the power button does nothing, not even the charge indicator LED lights up when plugging in the powercord...

Now I assume the Mainboard is fried, a real bummer after just a few month...Should still be covered by the warranty and I really hope the HDs are fine so I won’t encounter a data loss from this mess...just wanted to hear ya‘ll thoughts, anyone had something similar happen?

EDIT: I ran the battery all the way empty earlier, but I surely doubt that this would cause such a problem...
 
Last edited:
Find a bootable USB diagnostic on the internet and try to load that. There is likely a key combination that let's you specify the device to boot from. If you can't boot from the USB, that's a pretty sure sign the laptop is fried. If you send it in, expect it to come back with the system drive reformatted. Hope you have a backup! You can try to pull the drive and copy it using an adapter on another machine. However, you have put yourself at risk by opening the machine in the first place. You may have voided the warranty.
 
Nov 25, 2021
2
0
10
0
Yeah no that's not possible, because the laptop does not boot at all. It's 100% dead, like aboslutely NO sign of life. No charging indicator LED, no reaction when pressing the powerbutton, no keyboard light, no screen flicker, no fan spinning, not a single click, absolutely nothing.

I'll try and see what can be done regarding the hard drives, I bought it direclty of the clevo-website back in April, so far I have no experience with their customer-support...
Up until now i did not open the device at all, the battery can be removed without opening the case. Even if, the laptop also has a service hatch at the back that can be removed to access RAM/Data-Storage/CPU/GPU, the user manual states that this can be opened for cleaning purposes without voiding the warranty.

I searched the web alot, seems like there are no other threads on that topic regarding this specific machine, so I might just be the one unlucky bastard....I know any tech can break any time and stuff like this is exactly why things like warranty exists, nontheless really annoying to see such an expensive device break after such a short time.
 
Thread starter Similar threads Forum Replies Date
G Laptop Tech Support 6
Highmaster2 Laptop Tech Support 2
K Laptop Tech Support 2
T Laptop Tech Support 2
C Laptop Tech Support 0
Hail Noob Laptop Tech Support 2
bb86 Laptop Tech Support 1
Toscano371 Laptop Tech Support 2
B Laptop Tech Support 3
O Laptop Tech Support 0
O Laptop Tech Support 3
elit90 Laptop Tech Support 1
R Laptop Tech Support 1
R Laptop Tech Support 1
D Laptop Tech Support 2
P Laptop Tech Support 1
T Laptop Tech Support 2
K Laptop Tech Support 5
H Laptop Tech Support 1
X Laptop Tech Support 4

ASK THE COMMUNITY