Clevo P150SM fps drops - bad heatsink?

gamerb0y

Commendable
Apr 17, 2016
8
0
1,510
0
I have Clevo P150SM with GTX 880m. My laptop was getting heat up so I decided to replace the thermal paste of the CPU and GPU. The CPU temp dropped but the GPU temp did not drop. It was still hanging around 93C. While playing battlefield 4, the GPU is 99% under load and after every 30 seconds or so, the fps drops to 20 and back to 80 to 100 and again 30 to 20 for 2 seconds or so.

I am thinking maybe my GPU heatsink has gone bad because I repasted it 3 times but the temp did not drop at all. When i took the back cover and placed it on its screen (bottom of the laptop uncovered vertical), the temp dropped to 80C but when i put the back cover on, same problem.

What I have done so far,
Cleaned the GPU Fan
Cleaned the GPU with rubbing alcohol and repasted with arctic mx-4
update the drivers, used old versions
reinstalled the windows

Nothing has worked so far. Has the heatsink gone bad? I have never heard this before. I touch pipes of the heatsink and they are both hot.

Any help would be appreciated :)
 

typosl1998

Estimable
Jun 15, 2015
5
0
4,520
1
It is very likely that it has gone bad. The card it probably underclocking itself due to the heat and cause those sudden moments of fps drop then it goes back to the default you have when it drops back down in temp and back and fourth.
 

gamerb0y

Commendable
Apr 17, 2016
8
0
1,510
0


Thanks for the reply. Is there anyway to monitor the gpu underclocking? I dont want to buy a new heatsink and then find out it wasnt a problem. ( I live in Belgium so returning it would cost me more than the price of heatstink)
 

gamerb0y

Commendable
Apr 17, 2016
8
0
1,510
0


Indeed this was the problem. The GPU voltage and core clock drops but when i limited the temp to 80C via msi after burner, the spikes didnt happen. Any chance the the GPU is faulty?
 

gamerb0y

Commendable
Apr 17, 2016
8
0
1,510
0


The fan speed is locked. I think its locked in bios and I dont know how to unlock it. I found clevo control center and put the maximum fan speed from there. I also placed a bottle cap under the feet of laptop on GPU side. I get around 85C. I have attached the log. ignore the first part as no cap was placed.

http://tinypic.com/r/2lsdyqo/9
 

typosl1998

Estimable
Jun 15, 2015
5
0
4,520
1
As for fully unlocking it i'm not familiar with your system so I'm sorry I can't really help with that, but if that is in fact the problem I'd search around for how to unlock it or maybe even get a laptop cooling pad
 

gamerb0y

Commendable
Apr 17, 2016
8
0
1,510
0


I found the solution to my problem. It was due to bad bios update. I rolled back to previous version and it solved all the problems
 
Thread starter Similar threads Forum Replies Date
R Laptop Tech Support 1
R Laptop Tech Support 1
D Laptop Tech Support 2
P Laptop Tech Support 1
T Laptop Tech Support 2
K Laptop Tech Support 5
H Laptop Tech Support 1
X Laptop Tech Support 4
G Laptop Tech Support 3
J Laptop Tech Support 1
M Laptop Tech Support 23
H Laptop Tech Support 3
M Laptop Tech Support 8
N Laptop Tech Support 8
NOOB2PRO Laptop Tech Support 1
NOOB2PRO Laptop Tech Support 1
V Laptop Tech Support 5
M Laptop Tech Support 20
R Laptop Tech Support 2
Z Laptop Tech Support 3

ASK THE COMMUNITY