Could it be Malware with this CPU usage %?

maris

Prominent
Dec 3, 2017
10
0
560
0
hello

i had some 100% CPU usage spikes in BF1 which dropped my FPS from 120 to 40-50 and decided to check what kind of usage for IDLE

so i restarted windows 10 and didn't open any software except Task manager, HWiNFO and startup programs
after almost 5mins i saw that CPU Thread usage was 83% and total CPU usage 51%



i was checking my PC with NOD 32 antivirus and Malwarebytes, but didn't found anything.
also i turned off all services which aren't windows 10 system services

is it virus or malware, which NOD 32 or Malwarebytes can't find or something else?
 

mdd1963

Distinguished


No, but, high cpu usage during games is a fact of life for 4c/8t, 7700K included....; powerful GPUs don't alleviate the stress, and, the very high frame rates they are capable of keep the CPU busier than if running a GTX1060, for instance... (BF1 at 1080P is GPU-limited, even faster quad cores only gain perhaps 1-2 fps average max...; it's possible whatever server you are connected with can't keep up with your framerates, so, see if your famerate is capped at 60 Hz....

If you are suffering form GPU/CPU frame rate issues, they should manifest themselves in singleplayer modes as well...
 

maris

Prominent
Dec 3, 2017
10
0
560
0
yes, but it was in 5mins IDLE time, so i would call it as spike and i am thinking why it spikes up to 83%, when its IDLE
 

maris

Prominent
Dec 3, 2017
10
0
560
0
as i said i tried NOD 32 antivirus and Malwarebytes, but didn't found anything...
maybe there is any other better malware scanner?
 

rgd1101

Polypheme
Moderator


I mean the virus/malware scan might be running when you idle it.
 

maris

Prominent
Dec 3, 2017
10
0
560
0
yes that is why i am worry about, but i don't know why i didn't found any with NOD 32 antivirus and Malwarebytes, at least NOD32 is one of best antiviruses

maybe any1 can suggest better malware checker than Malwarebytes?
 

rgd1101

Polypheme
Moderator
I think you are looking at it all wrong.

Let go back and figure out why the BF1 fps issue.
What is the full system spec? include make and model of the PSU
What the CPU/GPU temp and usage during the games?
 

maris

Prominent
Dec 3, 2017
10
0
560
0
i7 7700 with Asus prime z270-k boost 4.3GHz - average usage 84%/70C, but i noticed that when i have huge FPS drop, then 100%/82C and it feels like 1s freeze
EVGA 1080 Hybrid - average 70%/47C, max 99%/52C
Crossair DDR4 2x 8Gb 3200
3x SSD
EVGA 650 G3 PSU
Cool Master 212 Led cooler

most of time CPU usage 100% is when i have to click Skip button after short cutscene in operation and then FPS drops down to 15FPS
but sometimes it happens during gameplay, then usage jump up to 100% and i feel like CPU is very busy and FPS drops down to ~40
 

mdd1963

Distinguished
If you are jumping from one scene to another in single player, and instantly jumping to/skipping a scene to jump to something else, the system must load this into video ram from your storage....

You cannot expect 100-125 fps constantly doing every last thing on the planet to include jumping from one scene to another...this is not Intel's Optane Year 2025 fantasy just yet, etc...... :)
 

maris

Prominent
Dec 3, 2017
10
0
560
0


i am not jumping from 1 to another, it happens when i join Multiplayer Operation mode...
every time when i join it, there is cut scene, then Skip button and join squad.. at that time i have huge FPS drop
 

maris

Prominent
Dec 3, 2017
10
0
560
0


ty... i will try to use Noctua NT-H1 therm paste.. i got it only today
 

mdd1963

Distinguished


Most BF1 servers I see have 60 Hz cap on frame rates anyway, do they not? (labeled as '60 Hz tick' in server settings summary?)

I'm not sure I'd gauge a drop in framerates as necessarily your issue.....

How do you know how well the actual server (is it a 7900X, or a mere Pentium Gold?) is handling the joining of 32-64 players all joining at once, possibly only on a 2-4 Mbps connection...?
 

maris

Prominent
Dec 3, 2017
10
0
560
0


that happens in all EU servers
i have 100Mbps optic connection

but those CPU lags seems like CPU is drawing objects, because at that time game shows whole map from top...
also i notice when i die and when i have to select Deploy spot, then CPU usage sometimes is 100%, but FPS doesn't drop that much
sometimes when i am running through whole map, then at some random places CPU jumps up to 100% and FPS drop is from 120 down to 50-30

back in a days i though it is connection lag, like package lost, but then i started to think how connection lag can make CPU usage 100%
 

mdd1963

Distinguished


No, but, high cpu usage during games is a fact of life for 4c/8t, 7700K included....; powerful GPUs don't alleviate the stress, and, the very high frame rates they are capable of keep the CPU busier than if running a GTX1060, for instance... (BF1 at 1080P is GPU-limited, even faster quad cores only gain perhaps 1-2 fps average max...; it's possible whatever server you are connected with can't keep up with your framerates, so, see if your famerate is capped at 60 Hz....

If you are suffering form GPU/CPU frame rate issues, they should manifest themselves in singleplayer modes as well...
 
Thread starter Similar threads Forum Replies Date
Me. Opanak Antivirus / Security / Privacy 1
S Antivirus / Security / Privacy 1
DCB007 Antivirus / Security / Privacy 4
N Antivirus / Security / Privacy 5
Nighty_z Antivirus / Security / Privacy 5
Ginko-san Antivirus / Security / Privacy 37
K Antivirus / Security / Privacy 2
A Antivirus / Security / Privacy 1
L Antivirus / Security / Privacy 1
N Antivirus / Security / Privacy 6
F Antivirus / Security / Privacy 2
T Antivirus / Security / Privacy 2
G Antivirus / Security / Privacy 2
D Antivirus / Security / Privacy 1
A Antivirus / Security / Privacy 1
R Antivirus / Security / Privacy 1
C Antivirus / Security / Privacy 2
D Antivirus / Security / Privacy 3
A Antivirus / Security / Privacy 5
RaZKaLz Antivirus / Security / Privacy 1

ASK THE COMMUNITY