Dell 7567 laptop: Forcing Windows 10 to use GTX 1050Ti instead of onboard GPU

Blue Skies

Jun 16, 2017
Hi all,

I would be grateful for some advice on a new laptop I bought for gaming. It is a Dell 7567 laptop with an Intel Core i7 7700HQ CPU and an NVIDIA GTX 1050Ti GPU.

I tried running Far Cry 4 on it and it is unplayable...the FPS in the main menu before the game starts is something like 0.2 FPS. Windows Task Manager says that the CPU utilization is 100% (absurd, for just the welcome screen, but the laptop's fans are also blowing at a high RPM).

So I checked out the NVIDIA GPU utilization using Nvidia's (NvGpuUtilization.exe) tool, and it seems throughout the entire launch of FC4, the utilization is 0%. Of course my NVIDIA drivers are the latest ones.

I then tried disabling the integrated GPU through the control panel's Display Adapters. It shows 2:
1. Microsoft Basic Display Adapter (<- disabled)
2. NVIDIA GeForce GTX 1050 Ti

When I then try to run NVIDIA's control panel (nvcplui.exe), it then gives the error message: "You are not currently using a display attached to an NVIDIA GPU."

Edit to add:
Just tried doing a benchmark on the GPU with Sisoft Sandra. It detects the NVIDIA GPU but says the GPU call failed.

I'm out of ideas here, so I would appreciate any advice you can offer.



Jun 17, 2010
My understanding is the Inspiron and Windows 10 automatically will switch over to the 1050ti when in game play. You should go to the Intel website and download the "Intel driver assistant" software. That will enable your machine to do the switching.