Digital TV problems with 7 of 8 channels

DelphiMary

Estimable
Mar 30, 2015
1
0
4,510
0
Large attic digital antenna, great HD TV/Tivo local reception for four years, until this year. Currently no signal (Tivo V52 or V53 error codes) for Ch. 7.1, 7.2, and 36; Ch. 18.1, 18.2, 18.3, and 42 are pixilated at random times, and thus unwatchable, leaving only Ch. 23 consistently available. Sometimes 7.1, 7.2 and 36 are there but pixilated, other times they’re not there at all. Oddly, for about a month late last summer something similar happened: all but Ch. 36 were messed up — but no Tivo error codes and no missing channels that time. Then the problems went away and TV reception was great again. Until now. It's worse this time. Tivo says antenna signal strength is in the correct range. Seems like maybe serious EMI, but I don't know how to check, or what to do if I'm right. Appreciate any help. Thanks.
 

schwatzz

Estimable
Jun 23, 2014
82
0
4,610
23
Sounds like some serious interference is going on. Look into getting some ferrite cores to attach to all your power cables, and video cables, and coaxial cable.
 
Thread starter Similar threads Forum Replies Date
I Streaming Video & TVs 3
E Streaming Video & TVs 2
B Streaming Video & TVs 2
W Streaming Video & TVs 2
reble Streaming Video & TVs 2
G Streaming Video & TVs 1
B Streaming Video & TVs 1
T Streaming Video & TVs 2
J Streaming Video & TVs 1
L Streaming Video & TVs 2
B Streaming Video & TVs 1
D Streaming Video & TVs 1
A Streaming Video & TVs 3
L Streaming Video & TVs 1
B Streaming Video & TVs 1
I Streaming Video & TVs 3
B Streaming Video & TVs 2
K Streaming Video & TVs 1
K Streaming Video & TVs 1
G Streaming Video & TVs 2

ASK THE COMMUNITY