Solved! External Graphics Card not working

Jan 25, 2019
2
0
10
0
I have a Dell Optiplex Usff 9020 and a Zotac 650 1gb destroyer tsi with a power supply for the card and a beast egpu adapter. Its all plugged in but my PC isn't detecting the card please help. -Jamo p.s My graphics card fans are spinning.
 

william p

Distinguished
Sep 22, 2010
38
0
18,610
9
That sounds like a mission impossible setup since USFF has no PCIe slots.
A- The BIOS would have no options for an external GPU. No reason to look for one.
B- Create a Ssytem Restore point, then in Safe Mode (F8) remove the old GPU drivers. See if the new GPU can run in Safe Mode. If not you might be USFFSOL.
 

william p

Distinguished
Sep 22, 2010
38
0
18,610
9
That sounds like a mission impossible setup since USFF has no PCIe slots.
A- The BIOS would have no options for an external GPU. No reason to look for one.
B- Create a Ssytem Restore point, then in Safe Mode (F8) remove the old GPU drivers. See if the new GPU can run in Safe Mode. If not you might be USFFSOL.
 
Jan 25, 2019
2
0
10
0


Yeah it didnt work thanks tho
 
Thread starter Similar threads Forum Replies Date
E Laptop General Discussion 1
P Laptop General Discussion 1
L Laptop General Discussion 2
A Laptop General Discussion 1
D Laptop General Discussion 2
Lutfij Laptop General Discussion 0
W Laptop General Discussion 2
G Laptop General Discussion 1
C Laptop General Discussion 1
A Laptop General Discussion 2
M Laptop General Discussion 1
G Laptop General Discussion 3
K Laptop General Discussion 2
A Laptop General Discussion 5
B Laptop General Discussion 4
R Laptop General Discussion 5
PetarV Laptop General Discussion 6
S Laptop General Discussion 3
S Laptop General Discussion 1
J Laptop General Discussion 1

ASK THE COMMUNITY