External monitor won't display but is recognised/detected

Status
Not open for further replies.

Richard_193

Commendable
Mar 2, 2016
2
0
1,510
0
I have a brand new out-of-the-box Dell S2716DG monitor. I connected it to my MSI laptop with Windows 10. The laptop recognises the monitor. However, the screen stays blank.

I tried the duplicate display function, extended displays. I have tried making my external monitor as primary, still no luck. When setting my Dell monitor as extended, the mouse can move over and I can move windows over but they just disappear. I have reinstalled my GeForce 740M graphics drivers to the latest drivers. I have tried changing resolutions on the external display as the Dell Monitor goes up to 2560 x 1440.

I have been able to use the same HDMI cable with my Samsung TV which works perfectly and I can connect my laptop without any problems.

I have tried taking out the power cord for the monitor and putting it back in. Turning on my PC with the Dell monitor connected. Still, no luck.

I have made sure on the Dell Monitor that the HDMI output/input option is selected and not the DP option. My Dell monitor screen also soon after goes into energy saving mode which I think is due to nothing being displayed.

I have installed the monitor drivers but that shouldn't affect anything.

Unfortunately, I don't have a VGA cable to test the other display connection. I also don't have another computer to test the monitor with. My Laptop doesn't have a DP port, only VGA and HDMI.

It also appears the HDMI port is using the Intel integrated graphics not the Nvidia graphics. It showed that in the Nvidia control panel under physX settings. I also have the latest drivers for the Intel graphics.

I checked the Drivers task Manager and the Dell S2716DG shows in the display option and I don't have any yellow exclamation marks in the drivers menu.

Any help would be much appreciated.

Richard
 
Last edited by a moderator:

nightlife120

Commendable
Apr 24, 2016
2
0
1,520
1
Hey,

I had the same problem. For some reason, my HDMI cable didn't work with the monitor I was using. I was trying to fix the problem for 2 hours by trying to diagnose the problem in Windows however the problem turned out to be the HDMI cable. I switched it out for a new one and it started working without any problems. Perhaps try that?

If it isn't that, then I suggest you return the monitor as it's probably defective.
 
Last edited by a moderator:
Hi,

That's a bit strange. :( You'll need to run some series of test to see which one really is faulty.
- Start with the Dell monitor, to prove the functionality of the monitor do test it with a different PC or laptop as well and see if it will work or not since your laptop does work fine using a different display or TV.
- If the Dell monitor will work with a different laptop do a clean install of the graphics card driver.
- Go to Device Manager and uninstall the Nvidia driver.
- Check Programs and Features as well and uninstall anything related to Nvidia.
- Once done, download and install the latest driver from the manufacturers site.
- Here's the link: http://www.geforce.com/drivers
- Reboot your laptop once the latest driver has been installed.
- Do also set Nvidia as the default graphics card after the reboot.
- http://nvidia.custhelp.com/app/answers/detail/a_id/2615/~/how-do-i-customize-optimus-profiles-and-settings%3F
- If all these will not work your last option would be to reinstall Windows.
 

Richard_193

Commendable
Mar 2, 2016
2
0
1,510
0
I have indeed done a clean install of the Geforce Nvidia 740M driver and checked windows update for any outstanding updates which there is not. How do set the default HDMI port to use the graphics card as default as from what I can see I can just select programs?

Any other suggestions would be great?

It is just very strange to not have the new monitor display my laptop screen yet recognise it and I'm able to move windows to the external display but unable to see anything due to the monitor showing a black screen and going into powersaving mode as a result....
 

nightlife120

Commendable
Apr 24, 2016
2
0
1,520
1
Hey,

I had the same problem. For some reason, my HDMI cable didn't work with the monitor I was using. I was trying to fix the problem for 2 hours by trying to diagnose the problem in Windows however the problem turned out to be the HDMI cable. I switched it out for a new one and it started working without any problems. Perhaps try that?

If it isn't that, then I suggest you return the monitor as it's probably defective.
 
Last edited by a moderator:

Abrix

Prominent
May 10, 2017
1
0
510
0
I have the exact same problem with the same monitor, both the HDMI and Displayport/USB C thunderbolt 3 adapter didn't work. I have a Dell XPS 15 9560, and called Dell support, who wanted me to return it.

Does anybody know a solution to this? I checked both the HDMI and Displayport cable work completely fine with other monitors? But the screen doesn't work with the other computer. Maybe it could be Intel HD graphics, which are on laptops/desktops hinders the connection? It is a G-sync monitor, 165 hz, 2560x1440
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
miluti Laptop Tech Support 3
M Laptop Tech Support 0
R Laptop Tech Support 5
P Laptop Tech Support 0
S Laptop Tech Support 2
C Laptop Tech Support 1
M Laptop Tech Support 2
P Laptop Tech Support 11
G Laptop Tech Support 2
J Laptop Tech Support 2
D Laptop Tech Support 6
T Laptop Tech Support 1
R Laptop Tech Support 1
G Laptop Tech Support 1
M Laptop Tech Support 1
N Laptop Tech Support 2
A Laptop Tech Support 1
U Laptop Tech Support 11
R Laptop Tech Support 1
S Laptop Tech Support 1

ASK THE COMMUNITY

TRENDING THREADS