FiiO E10K USB DAC not working

Jun 22, 2018
I've updated drivers, uninstalled & reinstalled, messed around with properties and even tried different usb cables to see if that made any difference. I can provide any extra information needed, any help would be much appreciated!
Jul 21, 2018

If you've selected Realtek Digital Output, you've chosen your PC's audio card (not the Fiio). If your USB connection works you should see the FiiO DAC in you options list.
Jan 2, 2019
Hello to anyone reading this... If you are having the problem where your Fiio E10k is not showing up in your sound manager - (Playback) Tab and the blue light is turning on with it plugged into the computer but still not showing up... the fix for me was the cable plugging in to the E10k was a bit loose and i had to kinda push it a bit harder to get the sound data to show up in the sound manager. although this was the fix now if the cable moves a little bit it will lose the connection and not show up in the sound manager so the DAC cant really move much unless i want to buy a new cable. Hope this helps -Riley
Thread starter Similar threads Forum Replies Date
B Audio 5
R Audio 1
A Audio 4
D Audio 0
A Audio 2
A Audio 0
E Audio 0
O Audio 1
Scoope Audio 1
AnnaXEliza Audio 0
xkratosx Audio 5
Serisly Audio 1
N Audio 0
J Audio 1
S Audio 4
P Audio 1
T Audio 1
E Audio 0
Kynai Audio 1
B Audio 3

Similar threads