gheed

Distinguished
Aug 15, 2011
23
0
18,560
0
Recently got a new laptop and I've been using Firefox 7.0.1 for a couple of days. However, I noticed that I was getting some pretty slow speeds in general. Obviously the ISP or router would be the typical problem but one of these times the pages stopped loading completely and Firefox crashed. I decided to see if the same thing was happening on Internet Explorer and I tried to load a video on Youtube in both browsers when the lag started again. It loaded normally in IE but wouldn't at all in Firefox, despite refreshing the page. I tried other pages and IE is working fine.

Anyone got a clue what the problem is here?
 

gheed

Distinguished
Aug 15, 2011
23
0
18,560
0
It's not the speed of the program itself that's the issue, when it is actually running I agree it loads pages very quickly. The internet speed is suffering with Firefox though, haven't had this happen before.
 

gheed

Distinguished
Aug 15, 2011
23
0
18,560
0
Tried reinstalling Firefox and the problem persisted. Tried out Opera and I think it's brilliant, fast and doesn't have the same issue. Thanks for helping anyway.
 

Kensida

Distinguished
Oct 3, 2011
8
0
18,510
0
Try clearing up the cache. Also uninstall any add-ons that are not used. It may help speed up.

Firefox has always been fast enough, as it has been optimized for better resource management as well as speed tuning for its page rendering.
 
Thread starter Similar threads Forum Replies Date
U Social Networking 2
A Social Networking 2
P Social Networking 1
Tolis_GR Social Networking 1
M Social Networking 1
D Social Networking 1
T Social Networking 3
Mason Methot Social Networking 5
B Social Networking 3
K Social Networking 3
U Social Networking 1
S Social Networking 2
M Social Networking 3
T Social Networking 25
N Social Networking 10
T Social Networking 5
S Social Networking 4
D Social Networking 2
5 Social Networking 1
Madhatter4 Social Networking 3

ASK THE COMMUNITY