Firestick audio issue with HTMI PORT 2 which works fine with tivo

katelevy

Prominent
Jan 15, 2018
2
0
520
1
Hello - bought myself an Amazon firestick - I am in UK and have a fairly old Phillips HD flatscreen - model - 26PF7521D/10 with 2 x HDMI ports Port #1 has my VirginMedia tivo connected - great picture and great audio. The firestick is in number #2 and the picture is fab, but there is no audio at all except the one second when I switch from HDMI#1 to HDMI #2 - Then it cuts out. I have updated software, restarted and turned off dobly. I swapped the ports to check the HTMI #2 worked and it worked fine with audio and the tivo - but with the Firestick just a great picture and no sound. Not ready to by a new telly right now. I also have a DVD contected via Ext 4 with red white and yellow connectors. Happy to get rid of that if need be. Happy to buy some kit but not a new TV right now (tax due etc).

All replies gratefully received

Thanks - non technical Kate
 

katelevy

Prominent
Jan 15, 2018
2
0
520
1
My neighbour fixed this! I simply had to change the TV settings using the TV remote menus on HDMI 2 to PC. All working fine now!!
 

katelevy

Prominent
Jan 15, 2018
2
0
520
1
My neighbour fixed this! I simply had to change the TV settings using the TV remote menus on HDMI 2 to PC. All working fine now!!
 
Thread starter Similar threads Forum Replies Date
S Streaming Video & TVs 3
xneo70 Streaming Video & TVs 2
R Streaming Video & TVs 2
LorrieT Streaming Video & TVs 0
D Streaming Video & TVs 8
K Streaming Video & TVs 1
M Streaming Video & TVs 5
A Streaming Video & TVs 2
Dman1983 Streaming Video & TVs 2
S Streaming Video & TVs 2
AnupamaPrakash Streaming Video & TVs 1
T Streaming Video & TVs 1
E Streaming Video & TVs 1
G Streaming Video & TVs 4
S Streaming Video & TVs 3
B Streaming Video & TVs 1
T Streaming Video & TVs 2
N Streaming Video & TVs 6
W Streaming Video & TVs 1
N Streaming Video & TVs 2

ASK THE COMMUNITY